Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454359 - Install CD image fails to boot with error 'vesamenu.c32: attempted DOS system call'
Summary: Install CD image fails to boot with error 'vesamenu.c32: attempted DOS system...
Keywords:
Status: CLOSED DUPLICATE of bug 452355
Alias: None
Product: Fedora
Classification: Fedora
Component: libvirt
Version: 8
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-07 22:58 UTC by David Mueller
Modified: 2008-07-09 09:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-09 09:48:15 UTC


Attachments (Terms of Use)

Description David Mueller 2008-07-07 22:58:01 UTC
Description of problem:

I have created a custom version of the Fedora 8 install CD using Revisor.  This
image fails to boot with libvirt-0.4.4-1.fc8.  When the virtual machine starts,
the process stops at the boot screen (the screen that states "to install in
graphical mode press ENTER, to install in text mode type 'linux text'", etc)
with the following error:

vesamenu.c32: attempted DOS system call

Any attempts to run the installer in both graphical and text mode fail.  A
Google search suggested that using "linux0" may fix the problem but did not do
so in this case, nor did "linux0 text".

After removing libvirt-0.4.4-1.fc8 and associated packages, and reinstalling
them with the updates repository disabled (to get the original Fedora 8 version,
libvirt-0.3.3-2.fc8), the install image works as expected.

There was some discussion of this on the Revisor-users mailing list as I
initially thought this was a Revisor issue.
http://lists.fedoraunity.org/pipermail/revisor-users/2008-July/000677.html

Version-Release number of selected component (if applicable):

libvirt-0.4.4-1.fc8

How reproducible:

Always

Steps to Reproduce:
1. Create custom install CD with revisor (may not be necessary, I haven't tested
with standard images)
2. Attempt to install using virt-install.
  
Actual results:

Install CD image fails to boot with error 'vesamenu.c32: attempted DOS system call'

Expected results:

Successful install

Comment 1 Daniel Berrange 2008-07-09 09:48:15 UTC

*** This bug has been marked as a duplicate of 452355 ***


Note You need to log in before you can comment on or make changes to this bug.