Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454352 - FC9 rsh
Summary: FC9 rsh
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: rsh
Version: 9
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Adam Tkac
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-07 21:31 UTC by Philip Goisman
Modified: 2013-04-30 23:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-21 09:59:40 UTC


Attachments (Terms of Use)
rsh strace output (deleted)
2008-07-07 21:31 UTC, Philip Goisman
no flags Details

Description Philip Goisman 2008-07-07 21:31:55 UTC
Description of problem: After setting up rsh on my target machine I attempt to
rsh/rcp to it.  The following error is received:

/usr/bin/rsh target_machine ls -al /home
/bin/bash: Permission denied

And there is no entry for this attempt on the target machine.

But when I use /root/rsh-strace.sh with the following code:

#!/bin/bash
/usr/bin/strace -f -o /tmp/rsh-server.trace /usr/sbin/in.rshd

in /etc/xinetd.d/rsh with server = /root/rsh-strace.sh,

rsh/rcp works, entries appear in /var/log/messages, and the 
rsh-server.trace file is created in /tmp.

Version-Release number of selected component (if applicable):

rsh-server-0.17-50.fc9.i386
rsh-0.17-50.fc9.i386

How reproducible:

After setting up rsh, execute rsh from a server to the target_machine.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:If more info is needed, please let me know.

Comment 1 Philip Goisman 2008-07-07 21:31:55 UTC
Created attachment 311205 [details]
rsh strace output

Comment 2 Philip Goisman 2008-07-18 23:06:19 UTC
There have been several updates since I submitted this bug.  rsh now works as
expected in FC9.  Hence, this bug may be closed.

Comment 3 Adam Tkac 2008-07-21 09:59:40 UTC
(In reply to comment #2)
> There have been several updates since I submitted this bug.  rsh now works as
> expected in FC9.  Hence, this bug may be closed.

Thanks for info. Closing


Note You need to log in before you can comment on or make changes to this bug.