Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454351 - pidgin hangs with enabled evolution plugin
Summary: pidgin hangs with enabled evolution plugin
Keywords:
Status: CLOSED DUPLICATE of bug 432815
Alias: None
Product: Fedora
Classification: Fedora
Component: pidgin
Version: 9
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-07 21:24 UTC by Christian Krause
Modified: 2018-04-11 09:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-03-24 15:10:13 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Debian BTS 422807 None None None Never
GNOME Bugzilla 523135 None None None Never

Description Christian Krause 2008-07-07 21:24:17 UTC
Description of problem:
pidgin hangs if I click on a contact when the evolution plugin is enabled

Version-Release number of selected component (if applicable):
pidgin-2.4.3-1.fc9.i386
evolution-data-server-2.22.2-1.fc9.i386

How reproducible:
right now 100% on my system, but it has not happened before - it is stated in
other similar bug reports (see below), that the problem does not happen all
times for all people...

Steps to Reproduce:
1. use pidgin to login into ICQ network
2. turn on evolution plugin
3. click on available contact
  
Actual results:
pidgin just hangs and doesn't repaint its windows anymore

Expected results:
pidgin should not hang ;-)

Additional info:
There are already a bunch of other bug reports (in debian, pidgin bug tracking,
and gnome bugzilla).
If needed I can provide a backtrace, but it is nearly identical to the
backtraces of the referenced bugs anyway. 

http://developer.pidgin.im/ticket/973
http://developer.pidgin.im/ticket/3820
http://bugzilla.gnome.org/show_bug.cgi?id=523135
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=422807

Comment 1 Stu Tomlinson 2008-07-08 13:53:20 UTC
Do you have a remote addressbook (eg. LDAP) configured in Evolution? is it
currently unavailable when you experience this problem with Pidgin?
This is probably a duplicate of bug 432815.

Comment 2 Christian Krause 2008-07-08 18:41:47 UTC
(In reply to comment #1)
> Do you have a remote addressbook (eg. LDAP) configured in Evolution? is it
> currently unavailable when you experience this problem with Pidgin?
> This is probably a duplicate of bug 432815.

I've checked this, and indeed, the problem goes away when I turn off the LDAP
addressbook (which does not really work ;-)  ).

On the other hand, the backtrace does not indicate an address book operation
like gevo_load_addressbook, so I'm not sure whether it is a real duplicate...

The backtrace on my system:
#0  0x00110416 in __kernel_vsyscall ()
#1  0x00b54b95 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x03a8569c in do_get_contacts (sync=<value optimized out>, 
    book=<value optimized out>, query=<value optimized out>, 
    contacts=<value optimized out>, error=<value optimized out>, 
    cb=<value optimized out>, closure=<value optimized out>) at e-book.c:2140
#3  0x03a858a4 in e_book_get_contacts (book=<value optimized out>, 
    query=<value optimized out>, contacts=<value optimized out>, error=Could not
find the frame base for "e_book_get_contacts".
)
    at e-book.c:2178
#4  0x00307363 in gevo_search_buddy_in_contacts (buddy=0x8bbb090, query=0x0)
    at eds-utils.c:130
#5  0x00304fd0 in blist_node_extended_menu_cb (node=0x8bbb090, menu=0xbfdcbcc8)
    at gevolution.c:271
#6  0x008022ea in purple_marshal_VOID__POINTER_POINTER (
    cb=<value optimized out>, args=<value optimized out>, 
    data=<value optimized out>, return_val=Could not find the frame base for
"purple_marshal_VOID__POINTER_POINTER".
) at signals.c:669
#7  0x00803109 in purple_signal_emit_vargs (instance=<value optimized out>, 
    signal=<value optimized out>, args=<value optimized out>) at signals.c:482
#8  0x0080327e in purple_signal_emit (instance=<value optimized out>, 
    signal=<value optimized out>) at signals.c:434
#9  0x007ba392 in purple_blist_node_get_extended_menu (n=<value optimized out>)
    at blist.c:2677




Comment 3 Warren Togami 2009-03-24 15:10:13 UTC

*** This bug has been marked as a duplicate of bug 432815 ***


Note You need to log in before you can comment on or make changes to this bug.