Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454342 - rt2x00 (rt61pci) fails to associate with wpa-encrypted network
Summary: rt2x00 (rt61pci) fails to associate with wpa-encrypted network
Keywords:
Status: CLOSED DUPLICATE of bug 453390
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 9
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-07 19:58 UTC by Klaas Hölscher
Modified: 2008-07-07 20:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-07 20:09:51 UTC


Attachments (Terms of Use)

Description Klaas Hölscher 2008-07-07 19:58:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9) Gecko/2008061015 Firefox/3.0

Description of problem:
The NetworkManager uses the rt2x00-rt61pci driver as with previous versions, but after the upgrade to the mentioned kernel it fails to associate, the applet ass for the passphrase, tries to connect, asks again, ..

-------------
from dmesg:
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:0e:2e:65:99:35
wlan0: RX authentication from 00:0e:2e:65:99:35 (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:0e:2e:65:99:35
wlan0: RX AssocResp from 00:0e:2e:65:99:35 (capab=0x411 status=0 aid=193)
wlan0: invalid aid value 193; bits 15:14 not set
wlan0: associated
wlan0: switched to short barker preamble (BSSID=00:0e:2e:65:99:35)
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
wlan0: switched to long barker preamble (BSSID=00:0e:2e:65:99:35)
wlan0: RX disassociation from 00:0e:2e:65:99:35 (reason=8)
wlan0: disassociated
wlan0: associate with AP 00:0e:2e:65:99:35
wlan0: RX deauthentication from 00:0e:2e:65:99:35 (reason=6)
wlan0: deauthenticated
wlan0: authenticate with AP 00:0e:2e:65:99:35
wlan0: RX authentication from 00:0e:2e:65:99:35 (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:0e:2e:65:99:35
wlan0: RX ReassocResp from 00:0e:2e:65:99:35 (capab=0x411 status=0 aid=193)
wlan0: invalid aid value 193; bits 15:14 not set
wlan0: associated
wlan0: RX disassociation from 00:0e:2e:65:99:35 (reason=8)
wlan0: disassociated
wlan0: associate with AP 00:0e:2e:65:99:35
wlan0: RX deauthentication from 00:0e:2e:65:99:35 (reason=6)
wlan0: deauthenticated
wlan0: no IPv6 routers present
wlan0: authenticate with AP 00:0e:2e:65:99:35
wlan0: RX authentication from 00:0e:2e:65:99:35 (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:0e:2e:65:99:35
wlan0: RX ReassocResp from 00:0e:2e:65:99:35 (capab=0x411 status=0 aid=193)
wlan0: invalid aid value 193; bits 15:14 not set
----------------------------

only tested against my wpa-psk encrypted network!


Version-Release number of selected component (if applicable):
2.6.25.9-76.fc9.i686

How reproducible:
Always


Steps to Reproduce:
1.enter network into network-manager
2.be asked what the phrase is
3.watch the nm-applet animation until being asked again what the pass is

Actual Results:
a dialog from nm-applet nm-applet asked for passphrase

Expected Results:
should have been associated with the network

Additional info:

Comment 1 John W. Linville 2008-07-07 20:09:51 UTC

*** This bug has been marked as a duplicate of 453390 ***


Note You need to log in before you can comment on or make changes to this bug.