Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454313 - QTDIR isn't set in ppc64 buildroot
Summary: QTDIR isn't set in ppc64 buildroot
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: qt3
Version: rawhide
Hardware: ppc64
OS: Linux
high
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL: http://koji.fedoraproject.org/koji/ta...
Whiteboard:
Depends On:
Blocks: KDE41
TreeView+ depends on / blocked
 
Reported: 2008-07-07 16:44 UTC by Dominik 'Rathann' Mierzejewski
Modified: 2008-07-15 12:15 UTC (History)
3 users (show)

Fixed In Version: 3.3.8b-14.fc9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-15 12:15:32 UTC


Attachments (Terms of Use)

Description Dominik 'Rathann' Mierzejewski 2008-07-07 16:44:20 UTC
Description of problem:
ppc64 build of xdrawchem fails to complete, while x86_64 builds fine. Apparently
QT{INC,LIB}DIR isn't set.

Version-Release number of selected component (if applicable):
3.3.8b-13.fc9

How reproducible:
Always.

Steps to Reproduce:
1. koji build --scratch dist-f10
'cvs://cvs.fedoraproject.org/cvs/pkgs?rpms/xdrawchem/devel#xdrawchem-1_9_9-11_fc10'
  
Actual results:
checking QTINCDIR... configure: error: *** QTINCDIR must be defined, or
--with-qtincdir option given
error: 
Bad exit status from /var/tmp/rpm-tmp.42839 (%build)

Expected results:
checking QTINCDIR... /usr/lib64/qt-3.3/include
checking QTLIBDIR... /usr/lib64/qt-3.3/lib
checking for moc... /usr/lib64/qt-3.3/bin/moc
checking for uic... /usr/lib64/qt-3.3/bin/uic

Additional info:
See the URL for failed koji build logs.

Comment 1 Rex Dieter 2008-07-07 16:48:21 UTC
I'm fairly certain the bug here lies not with qt3.  I'm seeing other f10/ppc64
failures today too, like
http://koji.fedoraproject.org/koji/buildinfo?buildID=55010

Comment 2 Dominik 'Rathann' Mierzejewski 2008-07-07 16:50:58 UTC
Hm actually configure is looking for $QTDIR/include and $QTDIR/lib. I wonder why
it worked before.


Comment 3 Kevin Kofler 2008-07-07 16:55:51 UTC
I think Than's recent changes to the multilib wrappers for qt3 broke this.

Comment 4 Kevin Kofler 2008-07-07 18:17:04 UTC
I'm bumping the priority to High because this blocks the KDE41 introduction due 
to a weird dependency chain:
* kdeedu 4.1 needs the new openbabel.
* openbabel needs xdrawchem rebuilt.
* Thus, we cannot get KDE 4.1 pushed before this qt3 bug is fixed, as weird as 
it sounds. :-(

Comment 5 Rex Dieter 2008-07-07 18:29:53 UTC
Re: comment #3

Yep, 
mock-chroot> echo $QTDIR
/usr/lib/qt-3.3
mock-chroot> ls /usr/lib/qt-3.3
ls: cannot access /usr/lib/qt-3.3: No such file or directory


Comment 6 Rex Dieter 2008-07-07 18:32:16 UTC
If following the current approach, one solution could be to add a check for the
existence of the prefered qtdir, and if it doesn't exist, fall-back to the
"other" one.

Comment 7 Dominik 'Rathann' Mierzejewski 2008-07-07 19:03:02 UTC
(In reply to comment #3)
> I think Than's recent changes to the multilib wrappers for qt3 broke this.

But why only for ppc64 and not for x86_64?


Comment 8 Kevin Kofler 2008-07-07 19:14:47 UTC
Because ppc64 normally prefers 32-bit binaries, but in the buildroot we only 
have the 64-bit one, so qt3 doesn't find the preferred QTDIR and fails. Rex is 
now adding code to fallback to the non-preferred one. On x86_64, the 64-bit one 
is preferred, so this doesn't happen there.

Comment 9 Rex Dieter 2008-07-07 19:41:04 UTC
* Mon Jul 07 2008 Rex Dieter <rdieter@fedoraproject.org> - 3.3.8b-14
- QTDIR isn't set in ppc64 buildroot (#454313)
- /etc/profile.d/qt.sh leaks variable ARCH (#454260)

Comment 10 Kevin Kofler 2008-07-08 13:11:25 UTC
qt3-3.3.8b-14.fc9 is now in dist-f9-override, qt3-3.3.8b-14.fc10 is now in 
Rawhide, so builds should work again now.

Comment 11 Fedora Update System 2008-07-08 13:43:10 UTC
qt3-3.3.8b-14.fc9 has been submitted as an update for Fedora 9

Comment 12 Fedora Update System 2008-07-15 12:15:28 UTC
qt3-3.3.8b-14.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.