Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454312 - Cannot create a custom errata if browser lang is Japanese
Summary: Cannot create a custom errata if browser lang is Japanese
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: WebUI
Version: 0.1
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Jesus M. Rodriguez
QA Contact: Red Hat Satellite QA List
URL: http://$SPACEWALK_SERVER/rhn/errata/m...
Whiteboard:
Depends On:
Blocks: space02
TreeView+ depends on / blocked
 
Reported: 2008-07-07 16:42 UTC by Satoru SATOH
Modified: 2009-09-17 06:59 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-17 06:59:29 UTC


Attachments (Terms of Use)
An experimental patch (deleted)
2008-07-08 06:41 UTC, Satoru SATOH
no flags Details | Diff
This is a patch fixes the problem and enable l10n-ed lables. (deleted)
2008-07-10 13:25 UTC, Satoru SATOH
no flags Details | Diff

Description Satoru SATOH 2008-07-07 16:42:12 UTC
+++ This bug was initially created as a clone of Bug #450658 +++

Description of problem:

If preferred language is Japanese (not English; locale != US), custom errata 
cannot be created because of the internal error.


Version-Release number of selected component (if applicable):
spacewalk 0.1 (rhn-java-sat-0.1-3.el5, ...)


How reproducible: always
 

Steps to Reproduce:
1. Login RHN Satellite web with non-US (web browser) configuration
2. [Errata] -> [Manage Errata]
3. [create new erratum]
4. Fill out the forms and try to create an errata


Actual results:
Internal error


Expected results:
An errata is successfully created.


Additional info:
If preferred lang is English (US) and fill out the forms (with same values), 
no problem occurs.

It seems that l10n-ed [Advisory Type] drop down menu item in the errata
creation form causes this issue.

Comment 1 Satoru SATOH 2008-07-08 06:41:34 UTC
Created attachment 311233 [details]
An experimental patch

I created an experimental patch to disable advisoryTypes l10n.	I also tryed to

show l10n-ed labels but it's not work well yet and commented in the patch.

I'm not familiar with neither Java nor Struts/JSP/... so that I might be doing
something wrong.

Anyway, could you please take a look at my patch?

Also, I cannot look satellite's source and am not sure but it may be applicable

to satellite, I think.

Comment 2 Satoru SATOH 2008-07-10 13:25:55 UTC
Created attachment 311481 [details]
This is a patch fixes the problem and enable l10n-ed lables.

Comment 3 Satoru SATOH 2008-07-10 13:27:37 UTC
I attached another patch which fixes this problem and not disable l10n-ed labels.
This should be better than the previous one, I think.

Comment 4 Jesus M. Rodriguez 2008-08-06 21:22:04 UTC
I'm in the process of testing the patch, I'll post back here once applied.

Comment 5 Jesus M. Rodriguez 2008-08-06 21:45:52 UTC
Patch applied to HEAD. 

http://git.fedorahosted.org/git/?p=spacewalk.git;a=commitdiff;h=7dd300ade36b67616229159a98be48b904fdf4ff

Thank you for the contribution.

Comment 6 Brandon Perkins 2008-09-04 20:34:45 UTC
Placing on bug space02 as it already made it into Git before the branching, so it should have landed in 0.2.

Comment 7 Devan Goodwin 2008-09-05 14:37:28 UTC
Verified logout is working ok now in spacewalk 0.2.

Comment 8 Devan Goodwin 2008-09-05 14:41:23 UTC
Ugh, verified the wrong firefox tab. Sorry. Back to modified.

Comment 9 Brad Buckingham 2008-09-05 18:55:25 UTC
Spacewalk: Verified errata creation when browser set to Japanese

Comment 10 Brad Buckingham 2008-09-05 18:57:42 UTC
Note: the verification was on Spacewalk 0.2

Comment 11 Miroslav Suchý 2009-09-17 06:59:29 UTC
Spacewalk is released for long time.


Note You need to log in before you can comment on or make changes to this bug.