Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454300 - saved queries with referencing column name Bug Number Ascending fail
Summary: saved queries with referencing column name Bug Number Ascending fail
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Bugzilla
Classification: Community
Component: Query/Bug List
Version: devel
Hardware: All
OS: Linux
low
low vote
Target Milestone: ---
Assignee: PnT DevOps Devs
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-07 15:51 UTC by R P Herrold
Modified: 2013-06-24 02:14 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-07-14 14:39:41 UTC


Attachments (Terms of Use)

Description R P Herrold 2008-07-07 15:51:07 UTC
possible addition for: https://bugzilla.redhat.com/show_bug.cgi?id=406071

Description of problem:

Running a saved query on my account, I get this error:

https://partner-bugzilla.redhat.com/buglist.cgi?cmdtype=runnamed&namedcmd=Russ%20-%20all%20RFE

Red Hat Bugzilla has suffered an internal error. Please save this page and send
it to bugzilla-owner@redhat.com with details of what you were doing at the time
this message appeared.

URL:
https://partner-bugzilla.redhat.com/buglist.cgi?cmdtype=runnamed&namedcmd=Russ%20-%20all%20RFE
The custom sort order specified in your form submission contains an invalid
column name Bug Number Ascending. 


Version-Release number of selected component (if applicable):

testing version at: https://partner-bugzilla.redhat.com/, showing: version
3.1.4+ at the top right


How reproducible:

log in as herrold@owlriver.com
choose saved query:  Russ - all RFE

Steps to Reproduce:
1.  as above
  
Actual results:

as above

Expected results:


Additional info:

Comment 1 R P Herrold 2008-07-07 15:52:10 UTC
also encountered in saved query:  DeferredRuss

Comment 2 David Lawrence 2008-11-24 21:06:05 UTC
Please reverify that this is still an issue with the latest version 3.2 of Bugzilla.

Comment 3 R P Herrold 2008-11-26 14:11:15 UTC
This remains an issue with the current bugzilla

I get a result error like this now:

 Your query returned 45739 bugs and Red Hat Bugzilla will only return 20000 or less bugs. Please back up and narrow your search criteria. If you feel your results were expected and your search criteria was correct, please send email to bugzilla-owner@redhat.com describing what you were doing and we will correct the error.

Please press Back and try again.

Alternatively, you can forget or edit the saved search 'DeferredRuss'. 

================================

when there should be less than an hundred or so; as such, I reverify that there is a problem

thanks

-- Russ herrold

Comment 4 David Lawrence 2008-11-26 15:27:46 UTC
Can you send me a link to the actual query.cgi URL? You can get this by clicking on the Edit link from the https://bugzilla.redhat.com/userprefs.cgi?tab=saved-searches page. I need to try to recreate the problem with my account.

Thanks

Comment 6 R P Herrold 2009-05-01 17:39:46 UTC
did information this help?

Comment 7 Noura El hawary 2009-05-03 11:04:36 UTC
Hi Herrold,

running the query you provided in comment #5 doesn't give me any errors, and it is working fine returning all bugs ordered correctly by bug number,, The error you got in comment #3 will be because there was a large number of bugs returned that can not be displayed at once that is why you were asked to narrow the search and it has nothing to do with ordering by bug number. Can you give us the name of your savedsearch that is still giving you errors.

Noura

Comment 8 R P Herrold 2009-07-14 14:39:41 UTC
I re-editted my searches that were causing issues and the issue no longer recurs -- closing


Note You need to log in before you can comment on or make changes to this bug.