Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4543 - panel crashes when windows placed on top
Summary: panel crashes when windows placed on top
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-core
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-08-16 09:32 UTC by tcc1000
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-11-17 21:49:54 UTC


Attachments (Terms of Use)

Description tcc1000 1999-08-16 09:32:32 UTC
I have had a lot of panel crashes with core dumps.
Unfortunately it is not easily reproducible, however it
usually happens when I have a few Netscape windows up:
bringing them to the front when overlapping a panel at the
bottom of the screen, and the panel crashes.

I have upgraded(?) to enlightenment-0.15.5-100 which seems
much more stable than either the default or updated RH
versions. I'm not sure if this is a Gnome problem or an
enlightenment one.

When I was using original RH version of enlightenment,
selecting the Default Gnome theme (plain grey) was much more
stable than the BrushedMetalBlue, for example.

It happens with both orignal and updated versions of imlib,
in case that has something to do with it.

Comment 1 Jay Turner 1999-08-16 18:36:59 UTC
I would recommend upgrading to the latest gnome packages that we have
on our updates site if you are not running the latest packages
already.  The errata posting referring to these updates is at:
http://www.redhat.com/corp/support/errata/RHEA1999024_01.html

Reopen this bug if the updates do not remedy your problem.

Comment 2 tcc1000 1999-08-17 08:34:59 UTC
Updated packages have the same problem, as does updated Netscape.

Comment 3 tcc1000 1999-08-18 10:33:59 UTC
I've tried upgrading to the RawHide packages. Same problem, although I
believe I can now reproduce the bug. Seems to be easiest with
Netscape.

Panel at bottom of screen; start Netscape and place window partially
overlapping the panel. Drag netscape (e set to opaque move) slowly off
panel. Panel crashes just as the netscape window reaches the edge.

.xsession-errors comes up with:
Gdk-WARNING **: GdkWindow 0x380006f unexpectedly destroyed

Gdk-WARNING **: GdkWindow 0x3800064 unexpectedly destroyed

(I have 2 panels).

I hope you can reproduce the bug now.

Comment 4 Elliot Lee 1999-09-13 20:29:59 UTC
I can't reproduce this here. A lot more info is needed if we are to
fix the bug...

Comment 5 tcc1000 1999-10-21 14:14:59 UTC
For the record, I've upgraded to RH6.1, october-gnome, enlightenment
0.16 and netscape-communicator 4.7, and it's still there. The panel
doesn't always crash, but usually does. It seems to restart a bit
better now, so that's a plus. Moving the netscape window slowly up
seems to cause the crash (almost) without fail:- just as soon as the
bottom of the netscape window reaches the top of the panel. I've tried
different themes, both in gnome and enlightenment, with the same
behaviour. What else can I tell you?

Comment 6 Elliot Lee 1999-10-29 14:43:59 UTC
OK, if you have October GNOME and the problem is still there, that is
useful information. Now we need to get a stack trace or something to
find out where the problem is. If you can work gdb, do you think you
could rebuild your gnome-core with debugging symbols, and get a stack
trace?

Comment 7 Elliot Lee 1999-11-17 21:49:59 UTC
Never have seen this problem at all - until solid details are available, will
assume it is specific to the one system.


Note You need to log in before you can comment on or make changes to this bug.