Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454296 - Compatibility support for previous releases
Summary: Compatibility support for previous releases
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: compat-gcc-32
Version: 5.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-07 15:19 UTC by Alan Matsuoka
Modified: 2018-10-19 20:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-07 15:32:07 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Alan Matsuoka 2008-07-07 15:19:59 UTC
Description of problem:
We are testing our app with RHEL5.1 x86_64, but some parts of the app are still
compiled on RHEL3 i386. These worked fine on RHEL4 i386 with the compat libs. I
see that RHEL5.1 does not have compat libs for RHEL3. I just wanted to check on
the official backwards compatibility policy of Red Hat. It looks like it is one
release back is supported, but not two. Is that correct? Thanks!

How reproducible:
.n.a

Version-Release number of selected component (if applicable):
5.1

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:

Additional Info:

We guarantee core libraries for n+2

compat-glibc-2.3.2-95.30 is not in RHEL5.

Since we do support stuff to N+2 then is should be in there. I tried building it
but I got
compat-gcc-32 >= 3.2.3 is needed by compat-glibc-2.3.2-95.30.i386
compat-gcc-32 >= 3.2.1-5 is needed by compat-glibc-2.3.2-95.30.i38

compat-gcc-32 is also not available for RHEL5 but compat-gcc-32-3.2.3-61.src.rpm
is available on the RHEL5.2 SRPM DVD.

Comment 1 Jakub Jelinek 2008-07-07 15:32:07 UTC
We guarantee runtime compatibility for n-2, but definitely not (and never did)
guarantee devel compatibility for n-2, only (selected parts of) n-1.
compat-glibc is devel only package (headers and linker stub for linking),
so it is ok that RHEL3 glibc isn't covered in RHEL5.  RHEL5 glibc (which is the
runtime package) supports RHEL2.1/RHEL3/RHEL4/RHEL5 linked programs and shared
libraries (as long as they don't invoke undefined behavior of course).

In RHEL5 from compat-gcc-32 src.rpm we just build the needed runtime library
package (compat-libstdc++-33).


Note You need to log in before you can comment on or make changes to this bug.