Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454291 - pango-devel.i386 has multilib conflicts with pango-devel.x86_64
Summary: pango-devel.i386 has multilib conflicts with pango-devel.x86_64
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: pango
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Behdad Esfahbod
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-07 15:03 UTC by Martin Stransky
Modified: 2009-07-14 15:03 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-07-14 15:03:08 UTC


Attachments (Terms of Use)

Description Martin Stransky 2008-07-07 15:03:39 UTC
Description of problem:

pango-devel.i386 can't be installed with pango-devel.x86_64 on x86_64 box.

Version-Release number of selected component (if applicable):


How reproducible:

Steps to Reproduce:

on x86_64:

1. #yum install pango-devel
2. #yum install pango-devel.i386
  
Actual results:

[komat@dhcp-lab-232 tmp436]$ sudo yum install pango-devel.i386
Loaded plugins: refresh-packagekit
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package pango-devel.i386 0:1.20.1-1.fc9 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 pango-devel             i386       1.20.1-1.fc9     fedora            320 k

Transaction Summary
=============================================================================
Install      1 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total size: 320 k
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
  file /usr/share/gtk-doc/html/pango/PangoEngineLang.html from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/PangoEngineShape.html from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/PangoFcDecoder.html from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/PangoFcFont.html from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/PangoFcFontMap.html from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/PangoMarkupFormat.html from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/PangoRenderer.html from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/index-1.10.html from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/index-1.12.html from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/index-1.14.html from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/index-1.16.html from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/index-1.18.html from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/index-1.2.html from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/index-1.20.html from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/index-1.4.html from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/index-1.6.html from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/index-1.8.html from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/index-all.html from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/index-deprecated.html from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/pango-ATSUI-Fonts.html from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/pango-Cairo-Rendering.html from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/pango-Coverage-Maps.html from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/pango-Engines.html from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/pango-Fonts.html from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/pango-FreeType-Fonts-and-Rendering.html
from install of pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/pango-Glyph-Storage.html from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/pango-Layout-Objects.html from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/pango-Miscellaneous-Utilities.html from
install of pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/pango-Modules.html from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/pango-OpenType-Font-Handling.html from
install of pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/pango-Scripts.html from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/pango-Tab-Stops.html from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/pango-Text-Attributes.html from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/pango-Text-Processing.html from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/pango-Version-Checking.html from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/pango-Vertical-Text.html from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/pango-Win32-Fonts-and-Rendering.html from
install of pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/pango-X-Fonts-and-Rendering.html from
install of pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/pango-Xft-Fonts-and-Rendering.html from
install of pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/pango-querymodules.html from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/pango.devhelp from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64
  file /usr/share/gtk-doc/html/pango/pango.devhelp2 from install of
pango-devel-1.20.1-1.fc9.i386 conflicts with file from package
pango-devel-1.20.1-1.fc9.x86_64

Error Summary
-------------


Expected results:

pango-devel.i386 lives with pango-devel.x86_64

Additional info:

Comment 1 Kirk Harrison 2008-07-15 15:10:08 UTC
same results can be achieved with later version (1.20.4-1.fc9) and
# yum install pango-devel.{i386,x86_64}

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 pango-devel             i386       1.20.4-1.fc9     updates           321 k

Transaction Summary
=============================================================================
Install      1 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         


Comment 2 Kirk Harrison 2008-07-15 15:24:09 UTC
Would just like to add that there is a work around for this problem. Download
the RPM (or look in /var/cache/yum/updates/packages after the above yum failure)
and force the install via:
# rpm -i --force pango-devel-1.20.4-1.fc9.i386.rpm
(or whatever version you are trying to install)

Comment 3 Bug Zapper 2009-06-10 01:58:03 UTC
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 Bug Zapper 2009-07-14 15:03:08 UTC
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.