Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454279 - Display flickering issues on RHEL 5.2
Summary: Display flickering issues on RHEL 5.2
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-i810
Version: 5.2
Hardware: All
OS: Linux
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact:
Depends On:
Blocks: 493054
TreeView+ depends on / blocked
Reported: 2008-07-07 13:50 UTC by Alan Matsuoka
Modified: 2011-06-29 18:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 493054 (view as bug list)
Last Closed: 2009-01-20 21:27:49 UTC
Target Upstream Version:

Attachments (Terms of Use)
X-org.log after trying interl driver (deleted)
2008-07-07 13:50 UTC, Alan Matsuoka
no flags Details
sosreport (deleted)
2008-07-07 14:10 UTC, Alan Matsuoka
no flags Details
messages (deleted)
2008-07-07 14:13 UTC, Alan Matsuoka
no flags Details
Xorg.0.log from the sosreport (deleted)
2008-07-15 23:00 UTC, Matěj Cepl
no flags Details
xorg.conf from the sosreport (deleted)
2008-07-15 23:01 UTC, Matěj Cepl
no flags Details

System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2009:0160 normal SHIPPED_LIVE xorg-x11-drv-i810 enhancement update 2009-01-20 16:05:17 UTC

Description Alan Matsuoka 2008-07-07 13:50:02 UTC
When using the i810 driver in RHEL 5.2 the customer experiences a similar
flickering as described when using the vesa driver.  It's different though in
that once it is flickering cycling between Ctrl+Alt+F1|F7 will not reconcile the
problem, the only solution is to reboot. The vesa driver does similar
flickering, but can be fixed by cycling between Ctl+Alt+F1|F7.  Customer has
tried this with various types of Monitors so we've ruled out a sync issue.

  1. Provide time and date of the problem
Happens everytime.
  2. Indicate the platform(s) (architectures) the problem is being reported against.
Dell Optiplex 745 (or 755) with intel 82Q963/Q965 cards.

  3. Provide clear and concise problem description as it is understood at the
time of escalation
Screen starts flickering/pulsating with the last color on the screen until
either reboot or cycle through virtual terminals depending on the driver being used.

It shouldn't flicker/pulsate like this.

  4. State specific action requested of SEG
Help in setting up a bugzilla or linking it to the existing:

  5. State whether or not a defect in the product is suspected
         * Provide Bugzilla if one already exists  might be related.

  6. If there is a proposed patch, make sure it is in unified diff format (diff
No patch that I'm aware of, but the previous bugzilla resulted in the following

Customer provided the following:
The good:
 The kernel no longer panics on shutting down X.

The bad:
 When using the i810 driver now I experience a similar flickering as described
when using the vesa driver.  It's different though in that once it is flickering
cycling between Ctrl+Alt+F1/F7 will not reconcile the problem, the only solution
I've found so far is to reboot.

The ugly:
 Vesa driver seems to be the same as before (flickering can occur some of the
time, but cycling between Ctrl+Alt+F1/F7 will usually fix it).

All tests done with:

Older sosreport from customer before update to RHEL 5.2
I'll try to go ahead and ask for an updated sosreport.


I suggested a change to the intel driver and got the following response:

Customer updated with the following.  It also looks like kdump is having issues
but hopefully we can get a vmcore soon:

If I turn on the intel driver, the system crashes when it attempts to utilize it
(both when you start X or when you try to boot with bootsplash).  The screen
goes blank (monitor light stays on), keyboard/numlock is unresponive, all
network traffic stops, I assume this is a kernel panic, but no "kernel panic"
info is displayed.  I can turn on kdump and grab a dump if you want.

I've attached the logs that show the output leading up to the crash, they don't
show anything interesting, just substantiate that loading the intel driver
caused it.  See the 'Xorg.0.log' and 'messages' attachments.

If I run 'startx' to cause it to lock up, the screen goes blank and nothing
happens.  I let it sit there for 30 minutes before power cycling it.  Nothing
was written to the crash location.  I'm pretty sure it's a kernel panic though
since the host stops responding to pings and my ssh session to the machine hangs.

Comment 1 Alan Matsuoka 2008-07-07 13:50:03 UTC
Created attachment 311150 [details]
X-org.log after trying interl driver

Comment 2 Alan Matsuoka 2008-07-07 14:10:03 UTC
Created attachment 311153 [details]

Comment 3 Alan Matsuoka 2008-07-07 14:13:31 UTC
Created attachment 311155 [details]

Comment 6 Matěj Cepl 2008-07-15 23:00:54 UTC
Created attachment 311892 [details]
Xorg.0.log from the sosreport

Comment 7 Matěj Cepl 2008-07-15 23:01:47 UTC
Created attachment 311893 [details]
xorg.conf from the sosreport

Comment 10 Adam Jackson 2008-09-19 14:30:38 UTC
1.6.509.15.el5 has been built against the new randr sources, which should at least make things fail differently.


Comment 14 Cameron Meadors 2008-12-03 17:04:11 UTC
Test this on Q963/Q965 with snap4 x86_64.  I do not see any flickering when I change to text consoles and back to X console.  Nor do I see any flickering with changing modes with xrandr.  I am using the intel driver.

Comment 15 Cameron Meadors 2008-12-09 19:59:25 UTC
Moving to verified.  Change it you retest and it doesn't work.

Comment 23 errata-xmlrpc 2009-01-20 21:27:49 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.