Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454273 - NetworkManager-gnome is not a dependency of NetworkManager
Summary: NetworkManager-gnome is not a dependency of NetworkManager
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: NetworkManager
Version: 5.2
Hardware: i386
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Dan Williams
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-07 12:13 UTC by Help Desk Reseach and Developement
Modified: 2008-07-07 16:16 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-07 16:16:37 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Help Desk Reseach and Developement 2008-07-07 12:13:43 UTC
Description of problem:
It seems that NetworkManager-gnome is not a dependency of NetworkManager, but
without the nm-applet from NetworkManager-gnome, NetworkManager is pretty useless.


Version-Release number of selected component (if applicable):
Latest repo it looks like... rpm query below

How reproducible:
-bash-3.2# rpm -e NetworkManager-gnome
-bash-3.2# rpm -q NetworkManager
NetworkManager-0.6.4-8.el5
-bash-3.2# 


Steps to Reproduce:
1. Refer to above

Actual results:
As NetworkManager-gnome is not a dependency it won't get pulled with yum when
you do a yum install NetworkManager. 

Expected results:
I am guessing the decision to keep -gnome separate was for KDE people or
something, but I think somehow the applet needs to get pulled when you do a yum
install NetworkManager.

Additional info:

Comment 1 Dan Williams 2008-07-07 16:16:37 UTC
It's an explicit decision to keep the two separate for exactly that reason. 
There is knetworkmanager which is the KDE replacement for nm-applet.  It's up to
the distro-composer to pull in the right applet (either nm-applet or
knetworkmanager) for the desktop that the distro is pulling in.  Fedora's
anaconda package list pulls this in by default, for example.


Note You need to log in before you can comment on or make changes to this bug.