Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454264 - file supportinfo differs between x86_64 and i386 by new line
Summary: file supportinfo differs between x86_64 and i386 by new line
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: redhat-release
Version: 4.7
Hardware: All
OS: Linux
low
low
Target Milestone: beta
: ---
Assignee: Nick Petrov
QA Contact: Alexander Todorov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-07 10:54 UTC by Alexander Todorov
Modified: 2009-05-18 20:28 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-05-18 20:28:37 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2009:1002 normal SHIPPED_LIVE redhat-release bug fix and enhancement update 2009-05-18 14:08:51 UTC

Description Alexander Todorov 2008-07-07 10:54:00 UTC
Description of problem:
File /var/lib/supportinfo differs between x86_64 and i386 by a new line.

Version-Release number of selected component (if applicable):
redhat-release-4WS-8

How reproducible:
always

Steps to Reproduce:
1. Diff the file contents from i386 and x86_64 package

  
Actual results:
--- /tmp/rpmdf/inputs/after/i386/redhat-release/payload/var/lib/supportinfo
2008-07-02 15:22:57.000000000 -0400
+++ /tmp/rpmdf/inputs/after/x86_64/redhat-release/payload/var/lib/supportinfo
2008-07-02 15:22:56.000000000 -0400
@@ -7,3 +7,4 @@
 Variant: WS
 MinRAM: 256 MB
 MaxCPU:	2
+


Expected results:
Files do not differ

Additional info:

Comment 2 Daniel Mach 2008-07-07 11:31:28 UTC
Does this apply also for other variants or is it WS only issue?

I'd like to close it as WONTFIX, since it's a minor glitch and redhat-release is
not (and will never be) a multilib package.

Comment 3 Alexander Todorov 2008-07-07 11:47:19 UTC
Seems like other variants have the new lines correct. Only WS has additional new
line for x86_64.

WONTFIX is not acceptable for QE. This is an easy fix and not fixing it will
results in unnecessary rpmdiff warnings which QE has to inspect manually and
waive every time. If redhat-release is never meant to be multilib just fix the
new line so that the multilib test case in rpmdiff reports the correct result.
Do not try to work around the problem please.

4.8 is OK for QE though.

Comment 8 Alexander Todorov 2009-02-24 15:17:38 UTC
VERIFIED with redhat-release-4AS-8.3

Comment 10 errata-xmlrpc 2009-05-18 20:28:37 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1002.html


Note You need to log in before you can comment on or make changes to this bug.