Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454233 - file -s ids ext3 filesystem as mp3
Summary: file -s ids ext3 filesystem as mp3
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: file
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Tomas Smetana
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-07 03:50 UTC by Jason Farrell
Modified: 2008-07-22 05:46 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-22 05:46:45 UTC


Attachments (Terms of Use)

Description Jason Farrell 2008-07-07 03:50:36 UTC
When using the new magic in file-4.24-4, it's no longer possible to id an ext3
block device as ext3 with 'file -s'

### with old magic (4.23):
[root@nano ~]# file -s /dev/mapper/vgr5-home
/dev/mapper/vgr5-home: Linux rev 1.0 ext3 filesystem data (needs journal
recovery) (large files)
### with new magic (4.24):
[root@nano dl]# file -s /dev/mapper/vgr5-home
/dev/mapper/vgr5-home: , 44.1 kHz, Stereo


After some poking around I've narrowed down the cause to an error in the updated
MP3 section:
--- 4.23-5.magic        2008-03-11 03:57:22.000000000 -0400
+++ 4.24-4.magic        2008-06-06 07:47:13.000000000 -0400
<snip>
@@ -592,22 +564,39 @@
 # modified to fully support MPEG ADTS

 # MP3, M1A
-0       beshort&0xFFFE  0xFFFA         MPEG ADTS, layer III, v1
+# modified by Joerg Jenderek
+# GRR the original test are too common for many DOS files
+# so don't accept as MP3 until we've tested the rate
+0       beshort&0xFFFE
 # rates
<snip>


Wrong number of fields. Must be >= 3. Works fine when using the old fields
(tested using ~/.magic).

Comment 1 Tomas Smetana 2008-07-21 11:21:21 UTC
I just pushed the new file-4.25 to rawhide and it seems to be working fine.  Can
you verify this please?  Thank you.

Comment 2 Jason Farrell 2008-07-21 14:26:36 UTC
Verified. Thanks.

Updated: file.x86_64 0:4.25-1.fc10 file-libs.x86_64 0:4.25-1.fc10
Complete!
[root@nano tmp]# file -s /dev/mapper/vgr5-home
/dev/mapper/vgr5-home: Linux rev 1.0 ext3 filesystem data (needs journal
recovery) (large files)
[root@nano tmp]# file -s /dev/mapper/vgr10-rootf9
/dev/mapper/vgr10-rootf9: Linux rev 1.0 ext4 filesystem data (needs journal
recovery) (extents) (large files)


Note You need to log in before you can comment on or make changes to this bug.