Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454232 - xterm should require xorg-x11-fonts-misc
Summary: xterm should require xorg-x11-fonts-misc
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: comps
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Jeremy Katz
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-07 03:34 UTC by Jens Petersen
Modified: 2014-03-17 03:15 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-10 23:22:31 UTC


Attachments (Terms of Use)

Description Jens Petersen 2008-07-07 03:34:27 UTC
Description of problem:
Since we no longer install xorg-x11-fonts-* by default xterm does have much
coverage of non-ascii now.  I suggest making it require xorg-x11-fonts-misc
which should help with that.

Steps to Reproduce:
1. run xterm on Japanese desktop
2. run "date" in xterm shell

Actual results:
1. warning appears:
"Warning: Cannot convert string \"nil2\" to type FontStruct"
2. empty spaces in place of Japanese characters in date

Expected results:
1. no warning
2. Japanese date to be displayed

Additional info:
Installing xorg-x11-fonts-misc solves the above problems.

Comment 1 Miroslav Lichvar 2008-07-08 15:35:04 UTC
I'm not sure that adding to xterm a dependency on a particular font is a good
idea. Maybe it would be better to add it to the Japanese support (and other
supported languages) in comps?

Comment 2 Bill Nottingham 2008-07-08 18:06:01 UTC
*cough* Use a terminal that supports a real font library.

Comment 3 Bill Nottingham 2008-07-08 18:07:08 UTC
Because, even if we add a requirement for -misc, that might catch some japanese,
but what about chinese? Thai? Arabic? etc.

We don't add requirements for fontconfig-using apps on specific language fonts,
so I'm not sure why xterm would require one.

Comment 4 Jens Petersen 2008-07-08 23:39:28 UTC
(In reply to comment #3)
> Because, even if we add a requirement for -misc, that might catch some japanese,
> but what about chinese? Thai? Arabic? etc.

Shrug, it would at least cover CJK.

> We don't add requirements for fontconfig-using apps on specific language fonts,
> so I'm not sure why xterm would require one.

True.  We used to install xorg-x11-fonts-misc by default...

(In reply to comment #2)
> *cough* Use a terminal that supports a real font library.

Maybe the question then is why are we installing xterm by default.

Shall I make it optional in comps?  Maybe that makes more sense: though
sometimes it is handy
to have xterm around for "emergencies".

Comment 5 Jens Petersen 2008-07-08 23:44:36 UTC
(It also purports to support Indic and Arabic...)

Or maybe we just need the GNU unifont.  Well there are various options. :)

Comment 6 Tony Fu 2008-09-10 03:09:37 UTC
requested by Jens Petersen (#27995)

Comment 7 Bill Nottingham 2008-09-10 23:22:31 UTC
Made optional.


Note You need to log in before you can comment on or make changes to this bug.