Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454216 - On dual core Intel PC: cdrecord cannot allocate memory-burning not possible
Summary: On dual core Intel PC: cdrecord cannot allocate memory-burning not possible
Keywords:
Status: CLOSED DUPLICATE of bug 220481
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: k3b
Version: 5.2
Hardware: i386
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Roman Rakus
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-06 20:37 UTC by ralf hartings
Modified: 2014-01-13 00:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-22 12:34:32 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description ralf hartings 2008-07-06 20:37:49 UTC
Description of problem:
cdrecord cannot allocate memory. Burning is not done. 

Version-Release number of selected component (if applicable):
K3B 0.12.17

How reproducible:
Every time

Steps to Reproduce:
1.start K3B
2.burn CD image
3.cdrecord cannot allocate memory
  
Actual results:

I get this message in the debug window while running K3B 0.12.17 using KDE
3.5.4-16.el5.centos on CentOS5.2.
Doesn't matter which iso i want to burn.
A full output from the debugger is below. Any comments what could be wrong?

System
-----------------------
K3b Version: 0.12.17

KDE Version: 3.5.4-16.el5.centos CentOS
QT Version:  3.3.6
Kernel:      2.6.18-92.1.6.el5PAE
Devices
-----------------------
_NEC DVD_RW ND-3520A 1.04 (/dev/scd0, ) at  [CD-R; CD-RW; CD-ROM; DVD-ROM;
DVD-R; DVD-RW; DVD+R; DVD+RW; DVD+R DL] [DVD-ROM; DVD-R Sequential; DVD-RW
Restricted Overwrite; DVD-RW Sequential; DVD+RW; DVD+R; DVD+R Double Layer;
CD-ROM; CD-R; CD-RW] [SAO; TAO; RAW; SAO/R96R; RAW/R96R; Restricted
Overwrite]

Used versions
-----------------------
cdrecord: 2.1

cdrecord
-----------------------
/usr/bin/cdrecord: Cannot allocate memory. WARNING: Cannot do mlockall(2).
/usr/bin/cdrecord: WARNING: This causes a high risk for buffer underruns.
/usr/bin/cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
/usr/bin/cdrecord: Permission denied. WARNING: Cannot set priority using
setpriority().
/usr/bin/cdrecord: WARNING: This causes a high risk for buffer underruns.
scsidev: '/dev/scd0'
devname: '/dev/scd0'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
/usr/bin/cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c 1.83 04/05/20
Copyright 1997 J. Schilling').
SCSI buffer size: 64512
Cdrecord-Clone 2.01 (cpu-pc-linux-gnu) Copyright (C) 1995-2004 Jörg
Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in this
version.
TOC Type: 1 = CD-ROM
Using libscg version 'schily-0.8'.
Driveropts: 'burnfree'
atapi: 1
Device type    : Removable CD-ROM
Version        : 5
Response Format: 2
Capabilities   : 
Vendor_info    : '_NEC    '
Identifikation : 'DVD_RW ND-3520A '
Revision       : '1.04'
Device seems to be: Generic mmc2 DVD-R/DVD-RW.
Current: 0x0009
Profile: 0x002B 
Profile: 0x001B 
Profile: 0x001A 
Profile: 0x0014 
Profile: 0x0013 
Profile: 0x0011 
Profile: 0x0010 
Profile: 0x000A 
Profile: 0x0009 (current)
Profile: 0x0008 (current)
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
Driver flags   : MMC-3 SWABAUDIO BURNFREE 
Supported modes: TAO PACKET SAO SAO/R96R RAW/R96R
Drive buf size : 1343488 = 1312 KB
FIFO size      : 4194304 = 4096 KB
/usr/bin/cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
/usr/bin/cdrecord: Permission denied. WARNING: Cannot set priority using
setpriority().
/usr/bin/cdrecord: WARNING: This causes a high risk for buffer underruns.
Track 01: data    15 MB        
Total size:       17 MB (01:44.89) = 7867 sectors
Lout start:       17 MB (01:46/67) = 7867 sectors
Current Secsize: 2048
ATIP info from disk:
  Indicated writing power: 5
  Is not unrestricted
  Is not erasable
  Disk sub type: Medium Type B, low Beta category (B-) (4)
  ATIP start of lead in:  -11607 (97:27/18)
  ATIP start of lead out: 359849 (79:59/74)
Disk type:    Short strategy type (Phthalocyanine or similar)
Manuf. index: 18
Manufacturer: Plasmon Data systems Ltd.
Blocks total: 359849 Blocks current: 359849 Blocks remaining: 351982
Starting to write CD/DVD at speed 32 in dummy SAO mode for single session.
Last chance to quit, starting dummy write in 2 seconds.
   1 seconds.
   0 seconds. Operation starts.
Waiting for reader process to fill input buffer ... input buffer ready.
trackno=0
BURN-Free is OFF.
Turning BURN-Free on
Sending CUE sheet...
/usr/bin/cdrecord: WARNING: Drive returns wrong startsec (0) using -150
Writing pregap for track 1 at -150
Starting new track at sector: 0
Track 01:    0 of   15 MB written.
/usr/bin/cdrecord: Input/output error. write_g1: scsi sendcmd: no error
CDB:  2A 00 00 00 00 BA 00 00 1F 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 04 00 00 00 00 0A 00 00 00 00 08 03 00 00
Sense Key: 0x4 Hardware Error, Segment 0
Sense Code: 0x08 Qual 0x03 (logical unit communication crc error
(ultra-dma/32)) Fru 0x0
Sense flags: Blk 0 (not valid) 
cmd finished after 0.003s timeout 200s
/usr/bin/cdrecord: A write error occured.
/usr/bin/cdrecord: Please properly read the error message above.
write track data: error after 380928 bytes
Writing  time:    5.291s
Average write speed  20.6x.
Fixating...
/usr/bin/cdrecord: Input/output error. flush cache: scsi sendcmd: no error
CDB:  35 00 00 00 00 00 00 00 00 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 03 00 00 00 BB 0A 00 00 00 00 0C 07 00 00
Sense Key: 0x3 Medium Error, Segment 0
Sense Code: 0x0C Qual 0x07 (write error - recovery needed) Fru 0x0
Sense flags: Blk 187 (not valid) 
cmd finished after 12.975s timeout 200s
WARNING: Some drives don't like fixation in dummy mode.
Trouble flushing the cache
Fixating time:   12.983s
/usr/bin/cdrecord: fifo had 70 puts and 7 gets.
/usr/bin/cdrecord: fifo was 0 times empty and 1 times full, min fill was
90%.
BURN-Free was never needed.

cdrecord command:
-----------------------
/usr/bin/cdrecord -v gracetime=2 dev=/dev/scd0 speed=32 -dao -dummy
driveropts=burnfree -eject -data
/home/ralf/Download/kiss/KiSS_DP-601_4[1].0.6b_fw.iso 


Expected results:


Additional info:
PC is dual core Intell on Motherboard P5k Pro.

Comment 1 Roman Rakus 2008-07-09 15:19:55 UTC
Maybe a duplicate of #220481

Comment 2 Roman Rakus 2008-07-22 12:34:32 UTC

*** This bug has been marked as a duplicate of 220481 ***


Note You need to log in before you can comment on or make changes to this bug.