Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454198 - Audio broken on big endian archs
Summary: Audio broken on big endian archs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: wildmidi
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-06 13:38 UTC by Ian Chapman
Modified: 2008-07-26 06:08 UTC (History)
0 users

Fixed In Version: 0.2.2-5.fc8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-09 02:48:31 UTC


Attachments (Terms of Use)
Fix audio on big endian archs (deleted)
2008-07-06 13:46 UTC, Ian Chapman
no flags Details | Diff

Description Ian Chapman 2008-07-06 13:38:34 UTC
Description of problem:

When playing any midi files, it just generates static noise.


Version-Release number of selected component (if applicable):
wildmidi-0.2.2-4.fc9.ppc.rpm

How reproducible:

Play a .mid file

Steps to Reproduce:
1. Play .mid file
2.
3.
  
Actual results:

Audio output is like static noise

Expected results:

The .mid should play correctly.

Additional info:

See attached patch.

Comment 1 Ian Chapman 2008-07-06 13:46:50 UTC
Created attachment 311100 [details]
Fix audio on big endian archs

If you look at the patch it seems counter intuitive at first, because it sets
SND_PCM_FORMAT_S16_LE and this fixes the audio on big endian archs but I think
it's related to the byte order of how the sample data is represented internally
by wildmidi vs the byteorder the sound device is expecting when opened. When 
SND_PCM_FORMAT_S16 is used (on BE archs) it either causes the sample data to be
byteswapped when it shouldn't be, or not byteswapped when it should be. Sorry
if the explanation is as clear as mud! :( Anyway, this patch may not be the
best solution but wildmidi works correctly on this ppc machine with it applied
and it should still work for LE archs.

Comment 2 Fedora Update System 2008-07-07 19:11:21 UTC
wildmidi-0.2.2-5.fc9 has been submitted as an update for Fedora 9

Comment 3 Fedora Update System 2008-07-07 19:18:24 UTC
wildmidi-0.2.2-5.fc8 has been submitted as an update for Fedora 8

Comment 4 Fedora Update System 2008-07-09 02:48:28 UTC
wildmidi-0.2.2-5.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2008-07-09 02:51:56 UTC
wildmidi-0.2.2-5.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2008-07-26 06:08:09 UTC
wildmidi-0.2.2-5.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.