Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454195 - yum update fails with bad tuple message
Summary: yum update fails with bad tuple message
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 9
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-06 12:21 UTC by Herbert Carl Meyer
Modified: 2014-01-21 23:03 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-07 19:11:51 UTC


Attachments (Terms of Use)
yum results (deleted)
2008-07-26 18:21 UTC, Herbert Carl Meyer
no flags Details

Description Herbert Carl Meyer 2008-07-06 12:21:15 UTC
Description of problem:

yum update fails with bad tuple message:

Setting up Update Process
Error: Package tuple (u'syslinux', u'i386', '0', u'3.63', u'1.rh9.rf') could not
be found in packagesack

Version-Release number of selected component (if applicable):
3.2.16

How reproducible:
~70%

Steps to Reproduce:
1.run yum check-update
2.run yum update or yum update "something"
  
Actual results:

Setting up Update Process
Error: Package tuple (u'syslinux', u'i386', '0', u'3.63', u'1.rh9.rf') could not
be found in packagesack


Expected results:
yum update proceeds

Additional info:

Sporadic, about 70%. Sometimes yum clean all clears it.
Seems to knock out other package update systems.
Fetching .rpms by hand and updating with rpm still works.

Comment 1 James Antill 2008-07-06 23:12:22 UTC
 Can you provide the output of "yum list updates", this looks like another repo.
error ... --skip-broken should help you out, and will probably provide more
insight into what is broken.


Comment 2 Herbert Carl Meyer 2008-07-07 13:04:11 UTC
output follows:

[root@vid ~]# yum list updates
Loaded plugins: refresh-packagekit
Updated Packages
perl.i386                                4:5.10.0-30.fc9        updates         
perl-Module-Pluggable.i386               1:3.60-30.fc9          updates         
perl-Pod-Escapes.i386                    1:1.04-30.fc9          updates         
perl-Pod-Simple.i386                     1:3.05-30.fc9          updates         
perl-libs.i386                           4:5.10.0-30.fc9        updates         
perl-version.i386                        3:0.74-30.fc9          updates         
[root@vid ~]# yum update
Loaded plugins: refresh-packagekit
Setting up Update Process
Error: Package tuple (u'syslinux', u'i386', '0', u'3.63', u'1.rh9.rf') could not
be found in packagesack
[root@vid ~]# 

looks like updates are coming from fedora updates

Comment 3 Jan Hutař 2008-07-22 12:21:22 UTC
Hello,
could you please try this?


rpm -q yum
rpm -V yum   # check if yum is OK

yum list syslinux   # we want to know where is that ugly package

yum clean all   # try to do a clean update with core repos
yum repolist
yum --disablerepo=\* --enablerepo=fedora --enablerepo=updates update


Because I have yum-3.2.16-4.fc9.noarch and haven't seen this issue yet.

Comment 4 Herbert Carl Meyer 2008-07-26 18:21:26 UTC
Created attachment 312711 [details]
yum results

Comment 5 Herbert Carl Meyer 2008-07-26 18:25:59 UTC
today's results ( I had to wait until it failed again, it's sporadic)
see attachment, Summary is: tuple failure, update were mostly from fedora
update, 1 pkg from atrpms. Requested rpm data collected, yum rerun with
--disable/--enable repo commands, update in progress. I will attach results as
soon as it completes.
I think it may be a repo conflict, I have a large number enabled to get xine
working.



Comment 6 James Antill 2008-08-07 19:11:51 UTC
 From what I understand: (u'syslinux', u'i386', '0', u'3.63', u'1.rh9.rf') means Something built for RHL 9, from rpmforge. Which is _very_ old, and I wouldn't recommend.

 I'm going to close this as "broken repo.".

Comment 7 Herbert Carl Meyer 2008-08-10 02:26:09 UTC
I will remove rpmforge from the repo list. I had it on the list to try for xine. xine does not work well on this system, the radeon driver is not good enough, and the new catalyst driver does not work. The real purpose of the system was a DVR, which does not work well yet.

Can you give me a short explanation of what a tuple is ? I suppose it will require explaining how yum works.

Comment 8 James Antill 2008-08-10 15:40:27 UTC
 A package tuple is basically a "package identifier". So a package like:

  abcd-0:1.2-3.i386

...would have the package tuple:

 ("abcd", "i386", "0", "1.2", "3")

...as I said before a "release" like '1.rh9.rf' implies something built for Red Hat Linux 9, on rpmforge.

Comment 9 Seth Vidal 2008-08-10 18:54:09 UTC
James,
 actually rh9 means fedora 9 on rpmforge. It's a bizarre choice but if you look at what they have, it was done on purpose.

Comment 10 Jan Hutař 2008-09-09 06:42:01 UTC
Hello,
have you solved it by disabling repos as noted in comment #5? If it is still a problem, just reopen the bug.


Note You need to log in before you can comment on or make changes to this bug.