Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454194 - DriverPath wrong in /etc/sysconfig/lcdproc/LCDd.conf
Summary: DriverPath wrong in /etc/sysconfig/lcdproc/LCDd.conf
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: lcdproc
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nicolas Chauvet (kwizart)
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-06 11:59 UTC by Patrick C. F. Ernzer
Modified: 2008-10-16 15:45 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-16 15:45:57 UTC


Attachments (Terms of Use)
gendiff /etc/sysconfig/lcdproc .orig (deleted)
2008-07-06 11:59 UTC, Patrick C. F. Ernzer
no flags Details | Diff

Description Patrick C. F. Ernzer 2008-07-06 11:59:29 UTC
Description of problem:
as shipped, lcdproc has a wrong DriverPath in /etc/sysconfig/lcdproc/LCDd.conf

Version-Release number of selected component (if applicable):
lcdproc-0.5.2-4.fc9

How reproducible:
always

Steps to Reproduce:
1. yum install lcdproc
2. start LCDd
  
Actual results:
no drivers found

Expected results:
default config should point at the correct driver directory

Additional info:
the required change is minimal, "DriverPath=/usr/lib/lcdproc/" is what is needed.

Comment 1 Patrick C. F. Ernzer 2008-07-06 11:59:29 UTC
Created attachment 311097 [details]
gendiff /etc/sysconfig/lcdproc .orig

Comment 2 Nicolas Chauvet (kwizart) 2008-07-08 12:31:19 UTC
The problem is that driver path is arch dependant and will need to tweak to
/usr/lib64 on lib64 multilibs systems.
This can be done as a dyn patch at buildtime. As there is no -devel package, we
will avoid multiarch conflict. I will fix in devel for now.

Comment 3 Nicolas Chauvet (kwizart) 2008-07-08 17:06:51 UTC
http://koji.fedoraproject.org/koji/taskinfo?taskID=703033
Build for rawhide is failing because of xmlto breakage
You can test this built specially for the initscripts (LSB compliant)
improvements...


Note You need to log in before you can comment on or make changes to this bug.