Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454187 - iwl4965 cannot obtain an ip address by DHCP with kernel 2.6.25.9-76
Summary: iwl4965 cannot obtain an ip address by DHCP with kernel 2.6.25.9-76
Keywords:
Status: CLOSED DUPLICATE of bug 453390
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 9
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-06 09:30 UTC by Andrea Bruna
Modified: 2008-07-06 18:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-06 18:19:28 UTC


Attachments (Terms of Use)
output of /var/log/messages while dhclient tries to obtain an ip address from the AP (deleted)
2008-07-06 09:30 UTC, Andrea Bruna
no flags Details

Description Andrea Bruna 2008-07-06 09:30:04 UTC
Description of problem:
The iwl4965 driver provided by kernel 2.6.25.9-76 does not seems to be able to
correctly obtain the network parameters by dhcp (and, to be honest, it does not
work even with a fixed ip and gateway).
The problem seems to rely on the kernel itself because with the same version of
the iwl4965 driver, networkmanager, wpa_supplicant and dhclient everything works
perfectly just by switching back to a previous version of the kernel (f.i.
2.6.25.6-55).
I attached a sample log that shows how dhclient goes in time-out even if
networkmanager has already authenticated with the AP.

Version-Release number of selected component (if applicable):
iwl4964 1.2.16kds provided by vmlinuz-2.6.25.9-76.fc9.x86_64

How reproducible:
Try to connect to a wireless network using an Intel 4965 card using kernel
2.6.25.9-76

Steps to Reproduce:
1. Enable Wireless Connection in NetworkManager
2. Put the proper authentication method and password
3. Wait for the network parameters
  
Actual results:
NetworkManager tries many time to obtain the network parameters but it fails.

Expected results:
NetWorkManager connects to the AP, receive the propers network parameters and
you can browse the local network (and/or internet).

Additional info:

Comment 1 Andrea Bruna 2008-07-06 09:30:04 UTC
Created attachment 311091 [details]
output of /var/log/messages while dhclient tries to obtain an ip address from the AP

Comment 2 Yanko Kaneti 2008-07-06 15:36:58 UTC
duplicate of bug 453390

Comment 3 Andrea Bruna 2008-07-06 18:19:28 UTC

*** This bug has been marked as a duplicate of 453390 ***


Note You need to log in before you can comment on or make changes to this bug.