Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454181 - valgrind reported problems
Summary: valgrind reported problems
Keywords:
Status: CLOSED DUPLICATE of bug 448516
Alias: None
Product: Fedora
Classification: Fedora
Component: evince
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-06 04:23 UTC by Ulrich Drepper
Modified: 2008-07-16 00:17 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-16 00:17:23 UTC


Attachments (Terms of Use)
Problematic PDF file (deleted)
2008-07-06 04:23 UTC, Ulrich Drepper
no flags Details

Description Ulrich Drepper 2008-07-06 04:23:38 UTC
Description of problem:
Using a PDF file I'll attach evince will hang without showing anything.  Running
it under valgrind shows two problems:

==23131== Memcheck, a memory error detector.
==23131== Copyright (C) 2002-2007, and GNU GPL'd, by Julian Seward et al.
==23131== Using LibVEX rev 1804, a library for dynamic binary translation.
==23131== Copyright (C) 2004-2007, and GNU GPL'd, by OpenWorks LLP.
==23131== Using valgrind-3.3.0, a dynamic binary instrumentation framework.
==23131== Copyright (C) 2000-2007, and GNU GPL'd, by Julian Seward et al.
==23131== For more details, rerun with: -v
==23131== 
==23131== Syscall param write(buf) points to uninitialised byte(s)
==23131==    at 0x3F2FA0DAD0: __write_nocancel (in /lib64/libpthread-2.8.so)
==23131==    by 0x3F39E0995E: (within /usr/lib64/libICE.so.6.3.0)
==23131==    by 0x3F39E0DB8F: _IceWrite (in /usr/lib64/libICE.so.6.3.0)
==23131==    by 0x3F39E0DC73: IceFlush (in /usr/lib64/libICE.so.6.3.0)
==23131==    by 0x4E7709B: (within /usr/lib64/libgnomeui-2.so.0.2201.0)
==23131==    by 0x4E78E82: (within /usr/lib64/libgnomeui-2.so.0.2201.0)
==23131==    by 0x3C8660B6DC: g_closure_invoke (in
/lib64/libgobject-2.0.so.0.1600.4)
==23131==    by 0x3C8661EFD5: (within /lib64/libgobject-2.0.so.0.1600.4)
==23131==    by 0x3C86620B9B: g_signal_emit_valist (in
/lib64/libgobject-2.0.so.0.1600.4)
==23131==    by 0x3C866210E2: g_signal_emit (in /lib64/libgobject-2.0.so.0.1600.4)
==23131==    by 0x4E78BEE: gnome_client_connect (in
/usr/lib64/libgnomeui-2.so.0.2201.0)
==23131==    by 0x4E79F5E: (within /usr/lib64/libgnomeui-2.so.0.2201.0)
==23131==  Address 0x53e0a34 is 12 bytes inside a block of size 1,024 alloc'd
==23131==    at 0x4A05174: calloc (vg_replace_malloc.c:397)
==23131==    by 0x3F39E05E51: IceOpenConnection (in /usr/lib64/libICE.so.6.3.0)
==23131==    by 0x3F3A2043B0: SmcOpenConnection (in /usr/lib64/libSM.so.6.0.0)
==23131==    by 0x4E78B6C: gnome_client_connect (in
/usr/lib64/libgnomeui-2.so.0.2201.0)
==23131==    by 0x4E79F5E: (within /usr/lib64/libgnomeui-2.so.0.2201.0)
==23131==    by 0x50F318D: gnome_program_postinit (in
/usr/lib64/libgnome-2.so.0.2200.0)
==23131==    by 0x50F354A: (within /usr/lib64/libgnome-2.so.0.2200.0)
==23131==    by 0x50F37CC: gnome_program_initv (in
/usr/lib64/libgnome-2.so.0.2200.0)
==23131==    by 0x50F38C3: gnome_program_init (in /usr/lib64/libgnome-2.so.0.2200.0)
==23131==    by 0x447C5C: (within /usr/bin/evince)
==23131==    by 0x3F2EE1E329: (below main) (in /lib64/libc-2.8.so)
==23131== 
==23131== Thread 2:
==23131== Conditional jump or move depends on uninitialised value(s)
==23131==    at 0x4A05B53: operator delete(void*) (vg_replace_malloc.c:342)
==23131==    by 0x3E8AE8A461: AnnotQuadrilaterals::AnnotQuadrilaterals(Array*,
PDFRectangle*) (in /usr/lib64/libpoppler.so.3.0.0)
==23131==    by 0x3E8AE8A780: AnnotLink::initialize(XRef*, Catalog*, Dict*) (in
/usr/lib64/libpoppler.so.3.0.0)
==23131==    by 0x3E8AE9184F: AnnotLink::AnnotLink(XRef*, Dict*, Catalog*,
Object*) (in /usr/lib64/libpoppler.so.3.0.0)
==23131==    by 0x3E8AE9490B: Annots::createAnnot(XRef*, Dict*, Catalog*,
Object*) (in /usr/lib64/libpoppler.so.3.0.0)
==23131==    by 0x3E8AE950A7: Annots::Annots(XRef*, Catalog*, Object*) (in
/usr/lib64/libpoppler.so.3.0.0)
==23131==    by 0x3E8AEF7B30: Page::displaySlice(OutputDev*, double, double,
int, int, int, int, int, int, int, int, Catalog*, int (*)(void*), void*, int
(*)(Annot*, void*), void*) (in /usr/lib64/libpoppler.so.3.0.0)
==23131==    by 0x3C8AA1694E: (within /usr/lib64/libpoppler-glib.so.3.0.0)
==23131==    by 0xD623505: (within /usr/lib64/evince/backends/libpdfdocument.so)
==23131==    by 0x41D83A: (within /usr/bin/evince)
==23131==    by 0x41BBB2: (within /usr/bin/evince)
==23131==    by 0x41C109: (within /usr/bin/evince)
==23131== 
==23131== Invalid free() / delete / delete[]
==23131==    at 0x4A05B9D: operator delete(void*) (vg_replace_malloc.c:342)
==23131==    by 0x3E8AE8A461: AnnotQuadrilaterals::AnnotQuadrilaterals(Array*,
PDFRectangle*) (in /usr/lib64/libpoppler.so.3.0.0)
==23131==    by 0x3E8AE8A780: AnnotLink::initialize(XRef*, Catalog*, Dict*) (in
/usr/lib64/libpoppler.so.3.0.0)
==23131==    by 0x3E8AE9184F: AnnotLink::AnnotLink(XRef*, Dict*, Catalog*,
Object*) (in /usr/lib64/libpoppler.so.3.0.0)
==23131==    by 0x3E8AE9490B: Annots::createAnnot(XRef*, Dict*, Catalog*,
Object*) (in /usr/lib64/libpoppler.so.3.0.0)
==23131==    by 0x3E8AE950A7: Annots::Annots(XRef*, Catalog*, Object*) (in
/usr/lib64/libpoppler.so.3.0.0)
==23131==    by 0x3E8AEF7B30: Page::displaySlice(OutputDev*, double, double,
int, int, int, int, int, int, int, int, Catalog*, int (*)(void*), void*, int
(*)(Annot*, void*), void*) (in /usr/lib64/libpoppler.so.3.0.0)
==23131==    by 0x3C8AA1694E: (within /usr/lib64/libpoppler-glib.so.3.0.0)
==23131==    by 0xD623505: (within /usr/lib64/evince/backends/libpdfdocument.so)
==23131==    by 0x41D83A: (within /usr/bin/evince)
==23131==    by 0x41BBB2: (within /usr/bin/evince)
==23131==    by 0x41C109: (within /usr/bin/evince)
==23131==  Address 0xf072370 is not stack'd, malloc'd or (recently) free'd


Version-Release number of selected component (if applicable):


How reproducible:
always using the provided file

Steps to Reproduce:
1.run evince using the attached file
2.
3.
  
Actual results:
under valgrind, see the messages above
without valgrind, evince hangs

Expected results:
shows document

Additional info:

Comment 1 Ulrich Drepper 2008-07-06 04:23:38 UTC
Created attachment 311087 [details]
Problematic PDF file

Comment 2 Bill Nottingham 2008-07-16 00:17:23 UTC

*** This bug has been marked as a duplicate of 448516 ***


Note You need to log in before you can comment on or make changes to this bug.