Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454162 - system-config-network crashed on start this component
Summary: system-config-network crashed on start this component
Keywords:
Status: CLOSED DUPLICATE of bug 461115
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-network
Version: 9
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-05 18:09 UTC by Tomas Machacek
Modified: 2008-11-28 14:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-11-28 14:37:08 UTC


Attachments (Terms of Use)

Description Tomas Machacek 2008-07-05 18:09:03 UTC
Description of problem:
system-config-network crashed on start this component

Version-Release number of selected component (if applicable):
1.5.10


How reproducible:
crash on start with next result:

Component: system-config-network
Version: 1.5.10
Summary: TB57735b68 connection.py:607:call_blocking:DBusException:
org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Hal was not
provided by any .service files

Traceback (most recent call last):
  File "/usr/sbin/system-config-network-tui", line 281, in <module>
    loadConfig(screen)
  File "/usr/sbin/system-config-network-tui", line 137, in loadConfig
    hardwarelist = getHardwareList()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line
759, in getHardwareList
    __HWList.load()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line
603, in load
    self.updateFromSystem()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line
483, in updateFromSystem
    self.updateFromHal(hdellist)
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line
447, in updateFromHal
    hal = NCBackendHal.NCBackendHal()
  File "/usr/share/system-config-network/netconfpkg/NCBackendHal.py", line 31,
in __init__
    self.halManagerObj = self._dbusBus.get_object("org.freedesktop.Hal",
"/org/freedesktop/Hal/Manager")
  File "/usr/lib/python2.5/site-packages/dbus/bus.py", line 244, in get_object
    follow_name_owner_changes=follow_name_owner_changes)
  File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 241, in __init__
    self._named_service = conn.activate_name_owner(bus_name)
  File "/usr/lib/python2.5/site-packages/dbus/bus.py", line 183, in
activate_name_owner
    self.start_service_by_name(bus_name)
  File "/usr/lib/python2.5/site-packages/dbus/bus.py", line 281, in
start_service_by_name
    'su', (bus_name, flags)))
  File "/usr/lib/python2.5/site-packages/dbus/connection.py", line 607, in
call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name
org.freedesktop.Hal was not provided by any .service files

Local variables in innermost frame:
byte_arrays: False
self: <dbus._dbus.SystemBus (system) at 0xb7bce3bc>
args: ('org.freedesktop.Hal', 0)
utf8_strings: False
bus_name: org.freedesktop.DBus
get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
object_path: /org/freedesktop/DBus
timeout: -1.0
signature: su
dbus_interface: org.freedesktop.DBus
message: <dbus.lowlevel.MethodCallMessage object at 0xb7fba150>
method: StartServiceByName

Comment 1 Jiri Moskovcak 2008-11-28 14:37:08 UTC

*** This bug has been marked as a duplicate of bug 461115 ***


Note You need to log in before you can comment on or make changes to this bug.