Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454147 - Eject closes the tray inmediately after eject
Summary: Eject closes the tray inmediately after eject
Keywords:
Status: CLOSED DUPLICATE of bug 453095
Alias: None
Product: Fedora
Classification: Fedora
Component: eject
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Zdenek Prikryl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-05 12:10 UTC by Sergio Pascual
Modified: 2008-07-08 07:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-08 07:51:30 UTC


Attachments (Terms of Use)

Description Sergio Pascual 2008-07-05 12:10:17 UTC
Description of problem:
When I unmount and eject a cd, the tray opens and closes inmediatelly, instead
of staying open

Version-Release number of selected component (if applicable):
eject-2.1.5-11.fc9.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Insert cd/dvd media
2. Get it mounted
3. Eject if, either with eject or with the gnome menu
  
Actual results:
The tray opens and then closes immediately. The media is mounted again

Expected results:
The tray opens, I get the media and then I close it 

Additional info:
I have checked the bug with three different machines: HP and Dell workstations
and a Dell laptop.

Comment 1 Andre Robatino 2008-07-05 15:06:48 UTC
Same behavior here with eject-2.1.5-11.fc9.i386 on an x86 box.

Comment 2 Zdenek Prikryl 2008-07-08 07:51:30 UTC
Hello,
It seems, that a bug is in HAL and its cdrom polling. When I disable HAL,
everything works fine. This bug is related to
https://bugzilla.redhat.com/show_bug.cgi?id=453095, so closing this bug as
duplicate.

*** This bug has been marked as a duplicate of 453095 ***


Note You need to log in before you can comment on or make changes to this bug.