Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454132 - Blender crashing (again!), but this time in Fedora 9
Summary: Blender crashing (again!), but this time in Fedora 9
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: mesa
Version: rawhide
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-05 06:16 UTC by David Chipman
Modified: 2008-07-08 16:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-08 16:07:32 UTC


Attachments (Terms of Use)
Backtrace of the latets blender (deleted)
2008-07-08 02:05 UTC, David Chipman
no flags Details

Description David Chipman 2008-07-05 06:16:24 UTC
Description of problem:
Blender crashes, accessing the OpenGL API function glRasterPos2f

Version-Release number of selected component (if applicable):
blender-2.46-1

How reproducible:
Always

Steps to Reproduce:
1. Start blender
2.
3.
  
Actual results:
Blender crashes with a "Segmentation fault"

Expected results:
Expoect the Blender UI to finish displaying, and the program ready to recieve
user input. 

Additional info:
Ask, and I'll see if I can find other things out.

Comment 1 Jochen Schmitt 2008-07-07 14:51:50 UTC
Hello,

Can you tell me, which graphic adapter do you use?

As second, it may be helpful, if you can create a backtrace.

Best Regards:

Jochen Schmitt

Comment 2 David Chipman 2008-07-08 02:05:26 UTC
Created attachment 311220 [details]
Backtrace of the latets blender

Comment 3 Jochen Schmitt 2008-07-08 15:24:52 UTC
Thank you for your backtrace. As far as I can see, it's seems to be a
Mesa/OpenGL related issue. So it may be nice, if you can tell me, which graphics
adapter do you use?

Best Regards:

Jochen Schmitt

Comment 4 David Chipman 2008-07-08 15:48:05 UTC
Hi Jochen, 

I'm using the following graphics card:
Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device

I hope this helps. I am using the "intel" driver. Previously, I had been using
the i810 driver.

Comment 5 Jochen Schmitt 2008-07-08 16:07:32 UTC
At first, I want to ask, if you have a full updated system. This may be
important, because there was any well-known issue releating with Intel graphics
adapters on F-9.

If the issue still exist, you should open a bug agains Mesa, becouse the
backtrace shows, that the crash occures on libdricore.so which is part of the
mesa-libGL package, so I have to assume, that your issue a coused by a
uncompletely OpenGL support from your graphic adapter.

For Information, on a NVidia graphic adapter with the closed-source graphic
driver I can start blender without any issues.

Best Regards:

Jochen Schmitt


Note You need to log in before you can comment on or make changes to this bug.