Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454126 - bzr lp-login xxx fails due to lack of CA Certificate
Summary: bzr lp-login xxx fails due to lack of CA Certificate
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: bzr
Version: 9
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Toshio Ernie Kuratomi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-04 23:27 UTC by Gene Czarcinski
Modified: 2008-07-05 04:59 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-05 04:59:17 UTC


Attachments (Terms of Use)

Description Gene Czarcinski 2008-07-04 23:27:13 UTC
Description of problem:
Ref: upstream bug: https://bugs.launchpad.net/bugs/245634

The fix to upstream bug #230223 has an undesirable feature .. it breaks
launchpad-login because there is no CA Certificate on the Fedora 9 system for
lauchpad's certificate.

launchpad-login does not fail on Fedora 8 because python-pycurl is not
installed.  I can circumvent the problem by uninstalling (--nodeps)
python-pycurl on the Fedora 9 system but this is really a very temporary solution.

Lokk at my upstream bug report.  Apparently, debia has a "ca-certificates"
package which contains certificates for common CAs.  What is the solution for
Fedora??

Version-Release number of selected component (if applicable):
Fedora 9, bzr-1.5

How reproducible:
yes

Comment 1 Gene Czarcinski 2008-07-04 23:39:39 UTC
Suggestion:  Create a new Fedora rpm which has commonly used ca-certificates
like debian does:  http://packages.debian.org/unstable/misc/ca-certificates

Given that debian has done all the work, this should be a simple solution to
implement.

Comment 2 Gene Czarcinski 2008-07-05 00:02:13 UTC
I attempted to use the ca-certificates rpm from F10 development  but it
conflicts with openssl on F9.  This ca-certificates rpm needs to be re-done for F9.

Comment 3 Toshio Ernie Kuratomi 2008-07-05 00:14:58 UTC
This is a bazaar bug.  Will add more information on the upstream bug.  If you'd
like to have ca-certificates backported to F9, please open a new bug against
that package to see what the maintainer thinks.

Comment 4 Gene Czarcinski 2008-07-05 04:04:01 UTC
I believe there is no need for the backport ... I beleive that openssl in Fedora
8/9 already provide the CA Certs in /etc/pki/tls/certs/ca-bundle.crt

The question is, how does whatever is checking the CA cert know to look there?
[debian has a different location]

more over at bzr

Comment 5 Gene Czarcinski 2008-07-05 04:30:40 UTC
Q: When you added the requirement for pycurl to the bzr package, did you do any
testing to see if lp-login worked?

Comment 6 Gene Czarcinski 2008-07-05 04:59:17 UTC
The message is from the curl (libcurl) package.

I believe that the problem is that launchpad's CA cert is missing but I am going
to close this report.

I am not sure if the fix is to backport the ca-certificates package or fix
openssl on Fedora 9.


Note You need to log in before you can comment on or make changes to this bug.