Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454108 - Firewall configuration under /usr/sbin/setup fails after system-config-firewall-tui upgrade
Summary: Firewall configuration under /usr/sbin/setup fails after system-config-firewa...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-firewall
Version: 9
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 454634 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-04 17:51 UTC by Ferdinand Badescu
Modified: 2008-07-09 21:49 UTC (History)
1 user (show)

Fixed In Version: 1.2.10-1.fc9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-09 21:49:46 UTC


Attachments (Terms of Use)

Description Ferdinand Badescu 2008-07-04 17:51:01 UTC
Description of problem: After upgrading system-config-firewall-tui to release
1.2.9-1.fc9 (previous version: 1.2.7-1.fc9), the "Firewall configuration" tool
under /usr/sbin/setup stopped working.
 
However, running "system-config-firewall-tui" allows one to configure the firewall.

Version-Release number of selected component (if applicable): 1.2.9-1.fc9


How reproducible: every time


Steps to Reproduce:
1. Upgrade system-config-firewall-tui and system-config-firewall to 1.2.9-1.fc9
2. (As root) Run setup (or /usr/sbin/setup)
3. Select "Firewall configuration" tool from the list.
  
Actual results: This is the error message, copied from stdin:

[root@RingBearer ~]# setup
Traceback (most recent call last):
  File "/usr/sbin/lokkit", line 25, in <module>
    os.execv(argv[0], argv)
OSError: [Errno 2] No such file or directory
[root@RingBearer ~]# 



Expected results: Start the configuration tool


Additional info: downgrading back to release 1.2.7-1.fc9 solved the problem.

Comment 1 Fedora Update System 2008-07-08 16:46:47 UTC
system-config-firewall-1.2.10-1.fc9 has been submitted as an update for Fedora 9

Comment 2 Fedora Update System 2008-07-09 02:54:02 UTC
system-config-firewall-1.2.10-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-firewall'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6251

Comment 3 Thomas Woerner 2008-07-09 14:41:52 UTC
*** Bug 454634 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2008-07-09 21:49:43 UTC
system-config-firewall-1.2.10-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.