Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454081 - Crashes before it starts up
Summary: Crashes before it starts up
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: devhelp
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 455730 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-04 13:17 UTC by Kjartan Maraas
Modified: 2018-04-11 15:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-05 10:19:06 UTC


Attachments (Terms of Use)

Description Kjartan Maraas 2008-07-04 13:17:10 UTC
Description of problem:

Backtrace:

Program received signal SIGSEGV, Segmentation fault.
0x01246dae in nsEmbedStream::AppendToStream (this=0x8081360, 
    aData=0x14c6b0 "<html><body bgcolor=\"white\"></body></html>", aLen=42)
    at nsEmbedStream.cpp:199
199						aLen); /* len */
Current language:  auto; currently c++
Missing separate debuginfos, use: debuginfo-install expat.i386 gamin.i386
gcc.i386 lcms.i386 libXau.i386 libXcomposite.i386 libXdmcp.i386 libXfixes.i386
libXi.i386 libXres.i386 libXt.i386 libcap.i386 libselinux.i386
(gdb) bt
#0  0x01246dae in nsEmbedStream::AppendToStream (this=0x8081360, 
    aData=0x14c6b0 "<html><body bgcolor=\"white\"></body></html>", aLen=42)
    at nsEmbedStream.cpp:199
#1  0x00c29382 in EmbedPrivate::AppendToStream (this=0x8cb1f20, 
    aData=0x14c6b0 "<html><body bgcolor=\"white\"></body></html>", aLen=42)
    at EmbedPrivate.cpp:689
#2  0x00c27772 in gtk_moz_embed_render_data (embed=0x8cab560, 
    data=0x14c6b0 "<html><body bgcolor=\"white\"></body></html>", len=42, 
    base_uri=0x14c4de "file:///", mime_type=0x14c4d4 "text/html")
    at gtkmozembed2.cpp:787
#3  0x0013e92f in dh_html_clear (html=0x8cb0b50) at dh-html.c:297
#4  0x00144c93 in window_open_new_tab (window=0x8982850, location=0x0)
    at dh-window.c:1219
#5  0x00146289 in dh_window_new (base=0x806eb30) at dh-window.c:578
#6  0x0013d346 in dh_base_new_window (base=0x806eb30) at dh-base.c:376
#7  0x080491c8 in main (argc=1, argv=0xbffff444) at dh-main.c:192
(gdb) 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Matěj Cepl 2008-07-22 10:30:46 UTC
*** Bug 455730 has been marked as a duplicate of this bug. ***

Comment 2 Kjartan Maraas 2008-07-22 10:46:53 UTC
Works in the latest rawhide push at least.


Note You need to log in before you can comment on or make changes to this bug.