Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454069 - Xorg crashed with coredump in EXA
Summary: Xorg crashed with coredump in EXA
Keywords:
Status: CLOSED DUPLICATE of bug 464866
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810
Version: 10
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-04 10:06 UTC by Zdenek Kabelac
Modified: 2009-10-22 12:56 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-06 09:28:06 UTC


Attachments (Terms of Use)
Xorg log file (deleted)
2008-07-04 10:06 UTC, Zdenek Kabelac
no flags Details

Description Zdenek Kabelac 2008-07-04 10:06:32 UTC
Description of problem:

I've got this coredump with EXA acceleration

#0  0x0000003181a32fa5 in raise (sig=<value optimized out>)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#1  0x0000003181a34b13 in abort () at abort.c:88
#2  0x00000000004f729d in FatalError ()
#3  0x000000000047a628 in xf86SigHandler ()
#4  <signal handler called>
#5  0x00007fb6745ca8a7 in DRILock ()
   from /usr/lib64/xorg/modules/extensions//libdri.so
#6  0x00007fb673f7ea77 in I830LeaveVT (scrnIndex=<value optimized out>, 
    flags=<value optimized out>) at i830_driver.c:3149
#7  0x00000000004610bd in AbortDDX ()
#8  0x00000000004f6bb8 in AbortServer ()
#9  0x00000000004f7285 in FatalError ()
#10 0x00007fb673f74e51 in I830WaitLpRing (pScrn=0xa0c710, n=131064, 
    timeout_millis=0) at i830_accel.c:150
#11 0x00007fb673f75223 in I830Sync (pScrn=0xa0c710) at i830_accel.c:204
#12 0x00007fb672ca553c in exaWaitSync ()
   from /usr/lib64/xorg/modules//libexa.so
#13 0x00007fb672ca6b05 in ExaDoPrepareAccess ()
   from /usr/lib64/xorg/modules//libexa.so
#14 0x00007fb672ca6c08 in exaPrepareAccessReg ()
   from /usr/lib64/xorg/modules//libexa.so
#15 0x00007fb672caed39 in ExaCheckComposite ()
---Type <return> to continue, or q <return> to quit---q
 from /usr/lib64/xorg/modules//libQuit

I'll attach also some weird Xorg log file (though not from this error case -
because of another crazy bug in gdm) filled with these messages:

[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] mieqEnequeue: out-of-order valuator event; dropping.


Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.4.99.905-2.20080701.fc10.x86_64

How reproducible:
Play 3D game :)

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Zdenek Kabelac 2008-07-04 10:06:32 UTC
Created attachment 311025 [details]
Xorg log file

Comment 2 Bug Zapper 2008-11-26 02:30:51 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Vedran Miletić 2009-09-06 09:28:06 UTC

*** This bug has been marked as a duplicate of bug 464866 ***


Note You need to log in before you can comment on or make changes to this bug.