Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454057 - should network proxy preferences set also environment variable https_proxy?
Summary: should network proxy preferences set also environment variable https_proxy?
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center
Version: 9
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Control Center Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-04 07:04 UTC by Luca Foppiano
Modified: 2008-07-04 14:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-04 14:30:33 UTC


Attachments (Terms of Use)

Description Luca Foppiano 2008-07-04 07:04:30 UTC
Description of problem:
When I set a proxy in network proxy preferences and I set https proxy or I
toggle the checkbox "use the same proxy for all protocols", system set the
environment variable http_proxy but not https_proxy.

Version-Release number of selected component (if applicable):
control-center-2.22.2.1-1.fc9.x86_64

How reproducible:
Just set proxy for all protocol, open a shell and type "env | grep proxy", you
should got only http_proxy and no_proxy environment variables.

Steps to Reproduce:
1. set proxy in "network proxy preferences" (set also https proxy or check the
"use the same proxy for all protocols")
2. open a terminal
3. type "env | grep proxy"
  
Actual results:
you get only http_proxy and no_proxy environment variables

Expected results:
you should get also https_proxy

Comment 1 Bastien Nocera 2008-07-04 14:30:33 UTC
It can't, because you can't change the envvar of already started shells. So
changing the proxy settings wouldn't change the proxy settings of already
started applications/shells.


Note You need to log in before you can comment on or make changes to this bug.