Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454045 - DrGeo reliably crashes
Summary: DrGeo reliably crashes
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: drgeo
Version: 9
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Eric Tanguy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-04 03:37 UTC by Przemek Klosowski
Modified: 2008-07-15 12:16 UTC (History)
0 users

Fixed In Version: 1.1.0-13.fc9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-15 12:16:51 UTC


Attachments (Terms of Use)

Description Przemek Klosowski 2008-07-04 03:37:13 UTC
Description of problem: DrGeo crashes often

Version-Release number: drgeo-1.1.0-12.fc9.i386

How reproducible: very reproducible


Steps to Reproduce:
1. start DrGeo
2. create New Geometric Figure (leftmost button on the top-side toolbar)
3. select Point (topmost tool on the left-side toolbar), click on the main canvas

Same result when running DrGeo on a sample file 
   drgeo /usr/share/drgeo/examples/figures/refraction.fgeo
and moving points around


  
Actual results:
as seen when run under gdb:

(drgeo:3694): libglade-WARNING **: Unknown GtkToolbar child property: width_request

(drgeo:3694): libglade-WARNING **: Unknown GtkToolbar child property: height_request

Program received signal SIGSEGV, Segmentation fault.
0x08074a36 in drgeoFigure::addToUndoQueue ()
(gdb) where
#0  0x08074a36 in drgeoFigure::addToUndoQueue ()
#1  0x08074c88 in drgeoFigure::moveItem ()
#2  0x0807eb88 in drgeoSelectTool::handleRelease ()
#3  0x0806dda4 in drgeoDrawableUI::handleRelease ()
#4  0x0806fd0d in drgeoGtkDrawable::releaseCallback ()
#5  0x0807078f in ?? ()
#6  0x078b42f6 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#7  0x08d2c600 in ?? ()
#8  0x08e25008 in ?? ()
#9  0x00000000 in ?? ()


Expected results:
lack of crash

Additional info:

Comment 1 Eric Tanguy 2008-07-04 10:00:13 UTC
You are right. I can reproduce the problem but i don't know how to solve it
because there is no more support upstream.

Comment 2 Przemek Klosowski 2008-07-08 06:52:08 UTC
 diff -u geo/drgeo_figure.cc*
--- geo/drgeo_figure.cc	2008-07-08 02:38:50.000000000 -0400
Bug results from a gint () function failing to return a value. The following
patch fixes the problem. Please test and send it up to Fedora updates, as this is
a neat application, and it would be a pity if it was left broken for long.

--- geo/drgeo_figure.cc	2008-07-08 02:38:50.000000000 -0400
+++ geo/drgeo_figure.cc~	2005-07-14 03:30:01.000000000 -0400
@@ -1309,7 +1309,7 @@
 gint
 drgeoFigure::preferedUndoLevel ()
 {
-  return atoi (drgeoConfigGet (":undoLevel"));
+  atoi (drgeoConfigGet (":undoLevel"));
 }
 
 void


Comment 3 Eric Tanguy 2008-07-08 20:47:36 UTC
Thanks your patch seems to solve the problem but there is a mistake in the patch : 
--- geo/drgeo_figure.cc	2008-07-08 02:38:50.000000000 -0400
+++ geo/drgeo_figure.cc~	2005-07-14 03:30:01.000000000 -0400
@@ -1309,7 +1309,7 @@
 gint
 drgeoFigure::preferedUndoLevel ()
 {
-  atoi (drgeoConfigGet (":undoLevel"));
+  return atoi (drgeoConfigGet (":undoLevel"));
 }
 
 void


Comment 4 Fedora Update System 2008-07-09 08:31:36 UTC
drgeo-1.1.0-13.fc9 has been submitted as an update for Fedora 9

Comment 5 Fedora Update System 2008-07-09 21:45:54 UTC
drgeo-1.1.0-13.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update drgeo'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6257

Comment 6 Fedora Update System 2008-07-15 12:16:49 UTC
drgeo-1.1.0-13.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.