Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454036 - iwl4965 does not connect to WPA network (kernel regression)
Summary: iwl4965 does not connect to WPA network (kernel regression)
Keywords:
Status: CLOSED DUPLICATE of bug 453390
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 9
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-04 00:24 UTC by Joel Eidsath
Modified: 2008-07-18 06:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-05 11:05:42 UTC


Attachments (Terms of Use)

Description Joel Eidsath 2008-07-04 00:24:43 UTC
My iwl4965 internal wireless card will not connect to my WPA network as of
kernel 2.6.25.9-76.fc9.x86_64. On the other hand, kernel 2.6.25.6-55.fc9.x86_64
continues to work just fine. 

Here is a link to a discussion where other people seem to be experiencing the
same problem: http://forums.fedoraforum.org/showthread.php?p=1040038#post1040038

The following are logs of what is happening:
Jul  3 17:51:44 tyr NetworkManager: <info>  Activation (wlan0/wireless) Stage 2 
of 5 (Device Configure) successful.  Connected to wireless network 'thrashome'.
Jul  3 17:51:44 tyr NetworkManager: <info>  Activation (wlan0) Stage 3 of 5 (IP 
Configure Start) scheduled.
Jul  3 17:51:44 tyr NetworkManager: <info>  Activation (wlan0) Stage 3 of 5 (IP 
Configure Start) started...
Jul  3 17:51:44 tyr NetworkManager: <info>  (wlan0): device state change: 5 -> 7
Jul  3 17:51:44 tyr NetworkManager: <info>  Activation (wlan0) Beginning DHCP tr
ansaction.
Jul  3 17:51:44 tyr NetworkManager: <info>  dhclient started with pid 3490
Jul  3 17:51:44 tyr NetworkManager: <info>  Activation (wlan0) Stage 3 of 5 (IP 
Configure Start) complete.
Jul  3 17:51:44 tyr dhclient: Internet Systems Consortium DHCP Client 4.0.0
Jul  3 17:51:44 tyr dhclient: Copyright 2004-2007 Internet Systems Consortium.
Jul  3 17:51:44 tyr dhclient: All rights reserved.
Jul  3 17:51:44 tyr dhclient: For info, please visit http://www.isc.org/sw/dhcp/
Jul  3 17:51:44 tyr dhclient: 
Jul  3 17:51:44 tyr NetworkManager: <info>  DHCP: device wlan0 state changed nor
mal exit -> preinit
Jul  3 17:51:44 tyr dhclient: Listening on LPF/wlan0/00:13:e8:6d:a2:93
Jul  3 17:51:44 tyr dhclient: Sending on   LPF/wlan0/00:13:e8:6d:a2:93
Jul  3 17:51:44 tyr dhclient: Sending on   Socket/fallback
Jul  3 17:51:44 tyr dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67
interval 5
Jul  3 17:51:45 tyr NetworkManager: <info>  (wlan0): supplicant connection state
change: 7 -> 6
Jul  3 17:51:45 tyr NetworkManager: <info>  (wlan0): supplicant connection state
change: 6 -> 7
Jul  3 17:51:45 tyr kernel: iwl4965: index 255 not used in uCode key table.
Jul  3 17:51:46 tyr NetworkManager: <info>  (wlan0): supplicant connection state
change: 7 -> 6
Jul  3 17:51:46 tyr kernel: iwl4965: index 255 not used in uCode key table.
Jul  3 17:51:46 tyr NetworkManager: <info>  (wlan0): supplicant connection state
change: 6 -> 7
Jul  3 17:51:46 tyr NetworkManager: <info>  (wlan0): supplicant connection state
change: 7 -> 0
Jul  3 17:51:46 tyr NetworkManager: <info>  (wlan0): supplicant connection state
change: 0 -> 2
Jul  3 17:51:47 tyr NetworkManager: <info>  (wlan0): supplicant connection state
change: 2 -> 4
Jul  3 17:51:47 tyr NetworkManager: <info>  (wlan0): supplicant connection state
change: 4 -> 5
Jul  3 17:51:47 tyr NetworkManager: <info>  (wlan0): supplicant connection state
change: 5 -> 6
Jul  3 17:51:48 tyr NetworkManager: <info>  (wlan0): supplicant connection state
change: 6 -> 7
:

Comment 1 Thomas Canniot 2008-07-05 09:36:20 UTC
Same here with b43 driver, with -76 kernel on i386. Works fine on -55 kernel :

Jul  5 11:28:07 localhost NetworkManager: <info>  (wlan0): supplicant connection
state change: 0 -> 2
Jul  5 11:30:48 localhost NetworkManager: <info>  Activation (wlan0) Stage 1 of
5 (Device Prepare) scheduled...
Jul  5 11:30:48 localhost NetworkManager: <info>  Activation (wlan0) Stage 1 of
5 (Device Prepare) started...
Jul  5 11:30:48 localhost NetworkManager: <info>  (wlan0): device state change:
6 -> 4
Jul  5 11:30:48 localhost NetworkManager: <info>  Activation (wlan0) Stage 2 of
5 (Device Configure) scheduled...
Jul  5 11:30:48 localhost NetworkManager: <info>  Activation (wlan0) Stage 1 of
5 (Device Prepare) complete.
Jul  5 11:30:48 localhost NetworkManager: <info>  Activation (wlan0) Stage 2 of
5 (Device Configure) starting...
Jul  5 11:30:48 localhost NetworkManager: <info>  (wlan0): device state change:
4 -> 5
Jul  5 11:30:48 localhost NetworkManager: <info>  Activation (wlan0/wireless):
connection 'Auto TECOM-AH4222-5C5382' has security, and secrets exist.  No new
secrets needed.
Jul  5 11:30:48 localhost NetworkManager: <info>  Config: added 'ssid' value
'TECOM-AH4222-5C5382'
Jul  5 11:30:48 localhost NetworkManager: <info>  Config: added 'scan_ssid'
value '1'
Jul  5 11:30:48 localhost NetworkManager: <info>  Config: added 'key_mgmt' value
'WPA-PSK'
Jul  5 11:30:48 localhost NetworkManager: <info>  Config: added 'psk' value
'<omitted>'
Jul  5 11:30:48 localhost NetworkManager: <info>  Config: added 'proto' value
'WPA RSN'
Jul  5 11:30:48 localhost NetworkManager: <info>  Config: added 'pairwise' value
'TKIP CCMP'
Jul  5 11:30:48 localhost NetworkManager: <info>  Config: added 'group' value
'WEP40 WEP104 TKIP CCMP'
Jul  5 11:30:48 localhost NetworkManager: <info>  Activation (wlan0) Stage 2 of
5 (Device Configure) complete.
Jul  5 11:30:48 localhost NetworkManager: <info>  Config: set interface ap_scan to 1
Jul  5 11:30:48 localhost NetworkManager: <info>  (wlan0): supplicant connection
state change: 2 -> 0
Jul  5 11:30:48 localhost NetworkManager: <info>  (wlan0): supplicant connection
state change: 0 -> 2
Jul  5 11:30:49 localhost NetworkManager: <info>  (wlan0): supplicant connection
state change: 2 -> 3
Jul  5 11:30:49 localhost NetworkManager: <info>  (wlan0): supplicant connection
state change: 3 -> 4
Jul  5 11:30:49 localhost NetworkManager: <info>  (wlan0): supplicant connection
state change: 4 -> 5
Jul  5 11:30:49 localhost NetworkManager: <info>  (wlan0): supplicant connection
state change: 5 -> 6
Jul  5 11:30:53 localhost NetworkManager: <info>  (wlan0): supplicant connection
state change: 6 -> 0
Jul  5 11:30:53 localhost NetworkManager: <info>  (wlan0): supplicant connection
state change: 0 -> 2
Jul  5 11:30:54 localhost NetworkManager: <info>  (wlan0): supplicant connection
state change: 2 -> 4
Jul  5 11:30:55 localhost NetworkManager: <info>  (wlan0): supplicant connection
state change: 4 -> 5
Jul  5 11:30:55 localhost NetworkManager: <info>  (wlan0): supplicant connection
state change: 5 -> 6
Jul  5 11:30:59 localhost NetworkManager: <info>  (wlan0): supplicant connection
state change: 6 -> 0
Jul  5 11:30:59 localhost NetworkManager: <info>  (wlan0): supplicant connection
state change: 0 -> 2
Jul  5 11:31:00 localhost NetworkManager: <info>  (wlan0): supplicant connection
state change: 2 -> 4
Jul  5 11:31:01 localhost NetworkManager: <info>  (wlan0): supplicant connection
state change: 4 -> 5
Jul  5 11:31:01 localhost NetworkManager: <info>  (wlan0): supplicant connection
state change: 5 -> 6
Jul  5 11:31:03 localhost NetworkManager: <info>  wlan0: link timed out.
Jul  5 11:31:05 localhost NetworkManager: <info>  (wlan0): supplicant connection
state change: 6 -> 0
Jul  5 11:31:05 localhost NetworkManager: <info>  (wlan0): supplicant connection
state change: 0 -> 2
Jul  5 11:31:06 localhost NetworkManager: <info>  (wlan0): supplicant connection
state change: 2 -> 4
Jul  5 11:31:07 localhost NetworkManager: <info>  (wlan0): supplicant connection
state change: 4 -> 5
Jul  5 11:31:07 localhost NetworkManager: <info>  (wlan0): supplicant connection
state change: 5 -> 6
Jul  5 11:31:11 localhost NetworkManager: <info>  (wlan0): supplicant connection
state change: 6 -> 0
Jul  5 11:31:11 localhost NetworkManager: <info>  (wlan0): supplicant connection
state change: 0 -> 2
Jul  5 11:31:12 localhost NetworkManager: <info>  (wlan0): supplicant connection
state change: 2 -> 4
Jul  5 11:31:13 localhost NetworkManager: <info>  (wlan0): supplicant connection
state change: 4 -> 5
Jul  5 11:31:13 localhost NetworkManager: <info>  (wlan0): supplicant connection
state change: 5 -> 6
Jul  5 11:31:13 localhost NetworkManager: <info>  Activation (wlan0/wireless):
association took too long.
Jul  5 11:31:13 localhost NetworkManager: <info>  (wlan0): device state change:
5 -> 6
Jul  5 11:31:13 localhost NetworkManager: <info>  Activation (wlan0/wireless):
asking for new secrets
Jul  5 11:31:13 localhost NetworkManager: <info>  (wlan0): supplicant connection
state change: 6 -> 0
Jul  5 11:31:28 localhost NetworkManager: <info>  wlan0: link timed out.

Comment 2 Bradley 2008-07-05 11:05:42 UTC
Fixed in -85

*** This bug has been marked as a duplicate of 453390 ***


Note You need to log in before you can comment on or make changes to this bug.