Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454023 - unwinding through k*probes slightly broken
Summary: unwinding through k*probes slightly broken
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.3
Hardware: ia64
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Anton Arapov
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-03 20:58 UTC by Frank Ch. Eigler
Modified: 2014-06-18 08:01 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-18 21:25:03 UTC


Attachments (Terms of Use)

Description Frank Ch. Eigler 2008-07-03 20:58:12 UTC
Excerpting from bug #253156 comment #6; two systemtap testsuite failures
appear to be correctable with a kernel patch.  The severity of this bug
is low, but so appears to be the risk.

> FAIL: backtrace of yyy_func4.return (3)
> FAIL: print_stack of yyy_func4.return (1)

To fix this issue, we need to introduce following kernel enhancement.
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=3661999a17b0397c7a93c200b280c55958ba3593;hp=965d747264c91ed206846d74ae09f757a36a373b

Comment 1 Anton Arapov 2008-07-18 08:37:47 UTC
Frank, I've tried to reproduce the issue on:
 - systemtap version 0.6.2/0.131 built 2008-03-12
 - kernel-2.6.18-92.1.6.el5
 - kernel-2.6.18-97.el5 with the fix from upstream applied
   http://people.redhat.com/aarapov/kernel/

and no luck... or otherwise - _luck_. testsuite tests done almost sucessfully
and absolutely identically on both kernels.

# make installcheck
[...]
FAIL: buildok/rpc-all-probes.stp
FAIL: buildok/signal-all-probes.stp
[...]
                === systemtap Summary ===
# of expected passes            459
# of unexpected failures        2
# of unexpected successes       1
# of expected failures          170
# of unknown successes          1
# of known failures             5
# of untested testcases         19
# of unsupported tests          1

N.B. make check gave me exactly the same FAILs.

Does it mean that failures magically disappear or somebody has something
misconfigured?
Did I miss something?

// putting bz in NEEDINFO

Comment 2 Frank Ch. Eigler 2008-07-18 21:25:03 UTC
Sorry, I made a mistake: bug #232489 comment #27
appears to include this patch already.


*** This bug has been marked as a duplicate of 232489 ***


Note You need to log in before you can comment on or make changes to this bug.