Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454021 - xmms segfault when opening xosd config
Summary: xmms segfault when opening xosd config
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xosd
Version: 8
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-03 20:21 UTC by Stefan Jensen
Modified: 2008-11-24 18:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-11-24 18:37:23 UTC


Attachments (Terms of Use)
Backtrace of xmms segfaulting (deleted)
2008-07-03 20:21 UTC, Stefan Jensen
no flags Details
gdb output running gdb xmms (deleted)
2008-11-18 06:27 UTC, Stefan Jensen
no flags Details

Description Stefan Jensen 2008-07-03 20:21:26 UTC
Description of problem:

xmms deqfaults, when i try to open the xosd plugin config dialog

Version-Release number of selected component (if applicable):

xmms-xosd-2.2.14-10.fc8
xmms-faad2-2.0-21.20050131.lvn8
xmms-crossfade-0.3.12-2
xmms-acme-0.4.3-8
xmms-1.2.10-36.fc7
bluecurve-xmms-skin-1.0.0-1.fc8
xmms-cdread-0.14-12.fc6
xmms-speex-0.9.1-11
xmms-libs-1.2.10-36.fc7
xmms-musepack-1.2-5.fc8
xmms-mp3-1.2.10-5.lvn6
xmms-flac-1.1.4-3.fc8
xmms-modplug-2.05-11.fc8


How reproducible:

Always

Steps to Reproduce:
1. start xmms
2. go to options/settings/plugins 
3. select "On Screen Display 2.2.14"
4. click "configure"
  
Actual results:

xmms segfault

Expected results:

opening configuration dialog for OSD

Additional info:

Please see attachment

Comment 1 Stefan Jensen 2008-07-03 20:21:26 UTC
Created attachment 310959 [details]
Backtrace of xmms segfaulting

Comment 2 Michael Schwendt 2008-11-16 12:31:42 UTC
Cannot reproduce.

Backtrace is not helpful as it lacks details and points into
pulseaudio-libs instead of xmms/xmms-xosd.

Please install the missing debuginfo packages. As root run:
debuginfo-install pulseaudio-libs xmms-xosd xmms

Then capture another backtrace.
Find more about that at: http://fedoraproject.org/wiki/StackTraces

Comment 3 Stefan Jensen 2008-11-18 06:26:08 UTC
ok, i installed the packages and run xmms with gdb. Please see the attached file with the output from gdb. 

best regards

Comment 4 Stefan Jensen 2008-11-18 06:27:28 UTC
Created attachment 323851 [details]
gdb output running gdb xmms

Comment 5 Michael Schwendt 2008-11-18 09:45:14 UTC
That's a crash in gtk2 (libgdk_pixbuf-2.0.so.0) whereas xmms and
xmms-xosd use gtk+ 1. Please show the output of

  ldd /usr/lib/xmms/General/libxmms_osd.so|grep pix

and

  ls -la /usr/lib/libgdk_*

Comment 6 Stefan Jensen 2008-11-18 16:44:07 UTC
Ok, here we go:

$ ldd /usr/lib/xmms/General/libxmms_osd.so|grep pix

	libgdk_pixbuf.so.2 => /usr/lib/libgdk_pixbuf.so.2 (0x00119000)

$ ls -la /usr/lib/libgdk_*

lrwxrwxrwx 1 root root     29 17. Jun 18:47 /usr/lib/libgdk_pixbuf-2.0.so -> libgdk_pixbuf-2.0.so.0.1200.8
lrwxrwxrwx 1 root root     29 15. Apr 2008  /usr/lib/libgdk_pixbuf-2.0.so.0 -> libgdk_pixbuf-2.0.so.0.1200.8
-rwxr-xr-x 1 root root 117124  7. Apr 2008  /usr/lib/libgdk_pixbuf-2.0.so.0.1200.8
lrwxrwxrwx 1 root root     22 23. Nov 2007  /usr/lib/libgdk_pixbuf.so.2 -> libgdk_pixbuf.so.2.0.0
-rwxr-xr-x 1 root root  90868 22. Aug 2007  /usr/lib/libgdk_pixbuf.so.2.0.0
lrwxrwxrwx 1 root root     34 17. Jun 18:47 /usr/lib/libgdk_pixbuf_xlib-2.0.so -> libgdk_pixbuf_xlib-2.0.so.0.1200.8
lrwxrwxrwx 1 root root     34 15. Apr 2008  /usr/lib/libgdk_pixbuf_xlib-2.0.so.0 -> libgdk_pixbuf_xlib-2.0.so.0.1200.8
-rwxr-xr-x 1 root root  65412  7. Apr 2008  /usr/lib/libgdk_pixbuf_xlib-2.0.so.0.1200.8
lrwxrwxrwx 1 root root     27 23. Nov 2007  /usr/lib/libgdk_pixbuf_xlib.so.2 -> libgdk_pixbuf_xlib.so.2.0.0
-rwxr-xr-x 1 root root 130552 22. Aug 2007  /usr/lib/libgdk_pixbuf_xlib.so.2.0.0

Comment 7 Michael Schwendt 2008-11-18 18:01:47 UTC
Reassigning to xosd, which is the right component for xmms-xosd.

Kevin, seen this before? Quick summary. xmms-xosd backtrace from
comment 4 crashes in gtk2's gdk_pixbuf instead of gtk+ 1's
gdk-pixbuf lib that was built with. As if it were preloaded.

0x001cdde1 in gdk_pixbuf_new_from_file () from /usr/lib/libgdk_pixbuf-2.0.so.0

Comment 8 Kevin Fenzi 2008-11-19 18:13:27 UTC
Very strange. No, I have not seen this... I don't have a f8 machine handy, but I guess I can install a virtual. Can you duplicate this? or is the reporter the only one seeing it?

Stefan: do you have any LD_PRELOAD set? output of 'env | grep -i ld' ?
Do you see the same thing if you make a new user and login and use it as that user?

Comment 9 Michael Schwendt 2008-11-19 20:12:44 UTC
No, can't reproduce it -- only if I preload. ;-)


Noticed the following in the attached memory map, though:

0027f000-0028d000 r-xp 00000000 fd:00 7798785    /usr/lib/gtk-2.0/modules/libgnomebreakpad.so
[...]
002a2000-002f5000 r-xp 00000000 fd:00 14682600   /usr/lib/bug-buddy/libbreakpad.so.0.0.0
[...]
002f6000-00312000 r-xp 00000000 fd:00 13674951   /usr/lib/libgdk_pixbuf-2.0.so.0.1200.8

bug-buddy! And preloading bug-buddy's libgnomebreakpad is one
way to crash xmms-xosd, of course. Just that bug-buddy here is
not active and not loaded either when starting xmms:

$ echo $GTK_MODULES
gnomebreakpad
$ xmms

Gtk-WARNING **: Failed to load module "libgnomebreakpad.so": libgnomebreakpad.so: cannot open shared object file: No such file or directory


Something else may be necessary to preload it.

Comment 10 Stefan Jensen 2008-11-20 14:30:53 UTC
(In reply to comment #8)

> Stefan: do you have any LD_PRELOAD set? output of 'env | grep -i ld' ?

No, none LD_PRELOAD Variables set.

> Do you see the same thing if you make a new user and login and use it as that
> user?

Yes.

> 0027f000-0028d000 r-xp 00000000 fd:00 7798785   
> /usr/lib/gtk-2.0/modules/libgnomebreakpad.so

Upps! This reminds me of a little change, that i've done long time ago.
I added the following to "gtk-2.0.conf", because of various complains from applications about "libgnomegreakpad.so" not found.

$ cat /etc/ld.so.conf.d/gtk-2.0.conf
#
/usr/lib/gtk-2.0/modules
/usr/lib64/gtk-2.0/modules

best regards

Comment 11 Michael Schwendt 2008-11-20 17:16:30 UTC
Well, that's the way you break Gtk+ 1.x in libgdk_pixbuf.so.2

Comment 12 Kevin Fenzi 2008-11-24 01:41:01 UTC
So, if you remove the ld.so.conf.d/gtk-2.0.conf file and restart, does everything work?

Comment 13 Stefan Jensen 2008-11-24 12:01:16 UTC
Hi,...

yes, i removed the lines, run "ldconfig" again and xmms/xosd works ok.

But with this, the following error came back:

Gtk-WARNING **: Failed to load module "libgnomebreakpad.so":
libgnomebreakpad.so: cannot open shared object file: No such file or directory

How can i avoid this?

greetings

Comment 14 Michael Schwendt 2008-11-24 12:13:45 UTC
Ignore it, or enhance the /usr/bin/xmms script to unset $GTK_MODULES

Comment 15 Kevin Fenzi 2008-11-24 18:37:23 UTC
I'm going to go ahead and close this now. 
If you spot anything further, please file a new bug.


Note You need to log in before you can comment on or make changes to this bug.