Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454000 - Fix curl-config usage, re-enable test suite
Summary: Fix curl-config usage, re-enable test suite
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-pycurl
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jeffrey C. Ollie
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-03 18:59 UTC by Ville Skyttä
Modified: 2008-07-25 20:00 UTC (History)
0 users

Fixed In Version: 7.18.2-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-25 15:21:13 UTC


Attachments (Terms of Use)
Fix curl-config usage (deleted)
2008-07-03 18:59 UTC, Ville Skyttä
no flags Details | Diff
Re-enable test suite (deleted)
2008-07-03 19:00 UTC, Ville Skyttä
no flags Details | Diff

Description Ville Skyttä 2008-07-03 18:59:49 UTC
For some reason python-pycurl's debuginfo in Rawhide is empty.  I looked into it
but could not find a reason and couldn't reproduce.

However, I found a couple of other things during the search: setup.py tries to
use curl-config --static-libs but no such thing exists at least in F-9.

Also, setting PYTHONPATH in %check should make it run the tests against the
built, not installed lib.

Comment 1 Ville Skyttä 2008-07-03 18:59:49 UTC
Created attachment 310951 [details]
Fix curl-config usage

Comment 2 Ville Skyttä 2008-07-03 19:00:35 UTC
Created attachment 310952 [details]
Re-enable test suite

Comment 3 Jeffrey C. Ollie 2008-07-25 15:21:13 UTC
Let me know if the debuginfo is still a problem.

Comment 4 Ville Skyttä 2008-07-25 20:00:32 UTC
-debuginfo seems ok now.


Note You need to log in before you can comment on or make changes to this bug.