Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453973 - add tap device support to RHEL5's ifup-eth script
Summary: add tap device support to RHEL5's ifup-eth script
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: initscripts
Version: 5.2
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: initscripts Maintenance Team
QA Contact: Brock Organ
URL:
Whiteboard:
: 228203 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-03 15:52 UTC by Scott Zahn
Modified: 2009-03-19 21:09 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-03-19 21:09:25 UTC


Attachments (Terms of Use)
patch to support tap device creation on boot (deleted)
2008-07-03 15:52 UTC, Scott Zahn
no flags Details | Diff

Description Scott Zahn 2008-07-03 15:52:54 UTC
I've simply added support for tap interfaces to be created on boot through the
ifup-eth script.  I did create one new config variable, a tap device owner can
be specified through the OWNER variable in ifcfg-tapX sysconfig files. 
Depending on how similar the ifup-eth scripts are between Fedora and Redhat,
this patch could be applied to Fedora as well.

Comment 1 Scott Zahn 2008-07-03 15:52:54 UTC
Created attachment 310936 [details]
patch to support tap device creation on boot

Comment 2 Bill Nottingham 2008-07-03 18:38:27 UTC
*** Bug 228203 has been marked as a duplicate of this bug. ***

Comment 3 Bill Nottingham 2009-03-19 21:09:25 UTC
I've committed a slightly modified version to the upstream initscripts repository; it will be in RHEL 6.

http://git.fedorahosted.org/git/?p=initscripts.git;a=commitdiff;h=242e38c178b6509496452d4a9d9e01024a415e64

This problem is resolved in the next release of Red Hat Enterprise Linux. Red Hat does not currently plan to provide a resolution for this in a Red Hat Enterprise Linux 5 update for currently deployed systems.

With the goal of minimizing risk of change for deployed systems, and in response to customer and partner requirements, Red Hat takes a conservative approach when evaluating changes for inclusion in maintenance updates for currently deployed products. The primary objectives of update releases are to enable new hardware platform support and to resolve critical defects.


Note You need to log in before you can comment on or make changes to this bug.