Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453959 - Update 1.4.99.905-1.20080701 does not work on HP Compaq 8510w
Summary: Update 1.4.99.905-1.20080701 does not work on HP Compaq 8510w
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mesa
Version: 9
Hardware: x86_64
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-03 14:53 UTC by Bryan Christ
Modified: 2018-04-11 13:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-05-04 08:13:27 UTC


Attachments (Terms of Use)
working config (before upgrade) (deleted)
2008-07-08 15:57 UTC, Bryan Christ
no flags Details
xorg log from broken (upgraded) config (deleted)
2008-07-08 16:21 UTC, Bryan Christ
no flags Details
xorg log from working configuration (deleted)
2008-07-08 16:23 UTC, Bryan Christ
no flags Details

Description Bryan Christ 2008-07-03 14:53:59 UTC
Description of problem:

Upgrading to package xorg-x11-server-Xorg-1.4.99.905-1.20080701.fc9.x86_64 from
the updates-testing repository does not work on HP Compaq 8510w.  After
upgrading Xorg will fail to start.  The integrated graphics is NVidia Quadro.  I
tried to get X working with the following servers:  vesa, vga, nv, nouveau, and
fbdev.  None of these would start.  In order to remedy the problem I had to
roll-back to the previous version with rpm --oldpackage.

I also updated my HP Compaq dx5150 but did not have this problem.

Version-Release number of selected component (if applicable):


How reproducible:  On some hardware


Steps to Reproduce:
1.  Install F9 on HP Compaq 8510w laptop
2.  Update to latest stable everything via yum
3.  Update xorg-x11-server to 1.4.99.905-1.20080701 from updates-testing
4.  Restart Xorg
  
Actual results:

X will cycle through all various settings trying to start and the fail.

Expected results:


Additional info:

QuickSpecs for the two hardware products used for testing can be found at these
URLs.

http://h18000.www1.hp.com/products/quickspecs/12727_div/12727_div.HTML
http://h18000.www1.hp.com/products/quickspecs/12105_div/12105_div.HTML

Comment 1 Matěj Cepl 2008-07-07 10:38:00 UTC
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 2 Bryan Christ 2008-07-07 14:54:45 UTC
Okay.  I will try to collect this information within the next few days.

Comment 3 Bryan Christ 2008-07-08 15:57:47 UTC
Created attachment 311286 [details]
working config (before upgrade)

Comment 4 Bryan Christ 2008-07-08 16:18:05 UTC
removing xorg.conf does not remedy the problem.

Comment 5 Bryan Christ 2008-07-08 16:21:07 UTC
Created attachment 311293 [details]
xorg log from broken (upgraded) config

Comment 6 Bryan Christ 2008-07-08 16:21:57 UTC
downgrading back to .902 build fixes the problem.

Comment 7 Bryan Christ 2008-07-08 16:23:28 UTC
Created attachment 311294 [details]
xorg log from working configuration

Comment 8 Matěj Cepl 2008-07-09 00:03:26 UTC
Missing /usr/lib64/dri/swrast_dri.so is from a package mesa-dri-drivers.

Comment 9 Bryan Christ 2008-07-11 15:33:11 UTC
Indeed, this is not an issue if you fetch the latest mesa build via yum.  I
would say this issue should can be closed but am also thinking that there should
be an rpm dependency between the two and there wasn't.

Comment 10 Bryan Christ 2009-04-30 15:21:25 UTC
I believe this bug can be closed as fixed.

Comment 11 Matěj Cepl 2009-05-04 08:13:27 UTC
Closing per comment 10


Note You need to log in before you can comment on or make changes to this bug.