Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453926 - Right-clicking nm-applet when keyring opens locks desktop.
Summary: Right-clicking nm-applet when keyring opens locks desktop.
Keywords:
Status: CLOSED DUPLICATE of bug 353451
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-03 09:38 UTC by Simon Goodall
Modified: 2008-10-17 16:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-17 16:07:20 UTC


Attachments (Terms of Use)

Description Simon Goodall 2008-07-03 09:38:07 UTC
Description of problem:
On several occasions I have had a problem that when I left click on the
nm-applet icon to see a list of networks, nm can cause the keyring password
prompt to appear.
The combination of both a left click menu and a keyring dialog box causes all
input to be ignored. The keyring dialog normally takes all the input focus,
however I believe the left click menu must somehow conflict with that.

Version-Release number of selected component (if applicable):
NetworkManager 0.7.0-0.9.4.svn3675.fc9.i386

How reproducible:
It's happened quite a few times.

Steps to Reproduce:
1. Have NM in an unassociated state, with keyring locked.
2. Have the wireless scanning/associate start (e.g. by turning on adapter)
3. Leftclick nm-applet to see list of wireless nets.
4. Leave menu open and wait for keyring unlock dialog to open.
5. Keyring dialog opens, prompting for pawssword.
6. Attempt to enter password
  
Actual results:
Move moves, but not keyboard input or mouse clicks are registered. Need to
switch out into console and manually kill the unlock + nm processes.

Expected results:
Expected to be able to enter password and continue.

Additional info:

Comment 1 Dan Williams 2008-10-17 16:07:20 UTC

*** This bug has been marked as a duplicate of bug 353451 ***


Note You need to log in before you can comment on or make changes to this bug.