Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453920 - kernel-2.6.25.9-76.fc9.i686 breaks wireless with iwl4965 somehow
Summary: kernel-2.6.25.9-76.fc9.i686 breaks wireless with iwl4965 somehow
Keywords:
Status: CLOSED DUPLICATE of bug 453390
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 9
Hardware: i686
OS: Linux
high
high
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-03 08:54 UTC by Christoph Höger
Modified: 2008-07-03 17:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-03 17:21:43 UTC


Attachments (Terms of Use)
Log of the Networkmanager session (deleted)
2008-07-03 10:05 UTC, Andrea Dell'Amico
no flags Details

Description Christoph Höger 2008-07-03 08:54:15 UTC
Description of problem:
I have a fine working wireless connection with 
kernel-2.6.25.6-55.fc9.i686 here (sending this report over it right now).
After upgrading the kernel I cannot get a valid ip via dhcp and after a while my
wireless connection disassociates (reason=7 or =3).

Steps to Reproduce:
1. Use NetworkManager to connect to Network
2. wait for association
3. wait for ip
  
Actual results:
timeout

Expected results:
waiting for ip should finish successfull after a while.

Comment 1 Andrea Dell'Amico 2008-07-03 10:02:09 UTC
It happens for me with intel 3945.
I have two access points, one at home and one at work, and the behaviour is the
same.
Authentication is WPA-PSK.


Comment 2 Andrea Dell'Amico 2008-07-03 10:05:54 UTC
Created attachment 310905 [details]
Log of the Networkmanager session

This is the log of the connection failures. I tried 3/4 times. There are
thousands of the following messages:

wlan0: RX deauthentication from 00:16:e0:04:fa:c0 (reason=7)
iwl3945: No space for Tx
iwl3945: Error sending REPLY_LEDS_CMD: iwl3945_enqueue_hcmd failed: -28
wlan0: RX deauthentication from 00:16:e0:04:fa:c0 (reason=7)
iwl3945: No space for Tx
iwl3945: Error sending REPLY_LEDS_CMD: iwl3945_enqueue_hcmd failed: -28
wlan0: RX deauthentication from 00:16:e0:04:fa:c0 (reason=7)
iwl3945: No space for Tx
iwl3945: Error sending REPLY_LEDS_CMD: iwl3945_enqueue_hcmd failed: -28
wlan0: RX deauthentication from 00:16:e0:04:fa:c0 (reason=7)
wlan0: RX deauthentication from 00:16:e0:04:fa:c0 (reason=7)
wlan0: RX deauthentication from 00:16:e0:04:fa:c0 (reason=7)
wlan0: RX deauthentication from 00:16:e0:04:fa:c0 (reason=7)
wlan0: RX deauthentication from 00:16:e0:04:fa:c0 (reason=7)
wlan0: RX deauthentication from 00:16:e0:04:fa:c0 (reason=7)
wlan0: RX deauthentication from 00:16:e0:04:fa:c0 (reason=7)

Comment 3 Chris Schanzle 2008-07-03 17:07:39 UTC
Me too on a Dell Vostro 1700 with iwl3945.

Interestingly, connecting to access point with no encryption worked with no
Rx/Tx errors, and transferred a 15MB file no problem.

Comment 4 John W. Linville 2008-07-03 17:21:43 UTC

*** This bug has been marked as a duplicate of 453390 ***


Note You need to log in before you can comment on or make changes to this bug.