Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453914 - Conflicts with libosip2 in SONAME Provides
Summary: Conflicts with libosip2 in SONAME Provides
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: compat-libosip2
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jeffrey C. Ollie
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-03 08:03 UTC by Michael Schwendt
Modified: 2014-01-21 06:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-03-08 20:49:30 UTC


Attachments (Terms of Use)

Description Michael Schwendt 2008-07-03 08:03:05 UTC
compat-libosip2 provides libosipparser2.so.3
libosip2 provides libosipparser2.so.3
  required by: compat-libosip2-devel - 2.2.2-16.fc9.i386
  required by: libeXosip2 - 3.1.0-1.fc9.i386
  required by: libosip2 - 3.1.0-1.fc9.i386
  required by: libosip2-devel - 3.1.0-1.fc9.i386
  required by: linphone - 2.1.1-1.fc9.i386
  required by: compat-libosip2 - 2.2.2-16.fc9.i386

Effectively, compat-libosip2 would never be chosen by Yum, as 
shortest pkg name wins.

Comment 1 Michael Schwendt 2008-07-03 08:14:16 UTC
Also the other lib:

compat-libosip2 provides libosip2.so.3
libosip2 provides libosip2.so.3
  required by: compat-libosip2-devel - 2.2.2-16.fc9.i386
  required by: libeXosip2 - 3.1.0-1.fc9.i386
  required by: libosip2 - 3.1.0-1.fc9.i386
  required by: libosip2-devel - 3.1.0-1.fc9.i386
  required by: linphone - 2.1.1-1.fc9.i386
  required by: compat-libosip2 - 2.2.2-16.fc9.i386


Comment 2 John Poelstra 2008-10-20 22:43:45 UTC
Can you be a little more descriptive in terms of defining what the bug is here and how to reproduce it?

Comment 3 Michael Schwendt 2008-10-20 23:32:36 UTC
You can reproduce it with your favourite package resolver or
even tools like repoquery, rpmdiff, rpmsoname.

I assume you know what a SONAME is how it matters with regard to
RPM packaging of shared libraries.

[...]

libosip2 = 3.0.x used to provide libosip2.so.2 and libosipparser2.so.2

Packages like linphone required libosip2.so.3 and libosipparser2.so.3
Note the different SONAME version.

compat-libosip2 = 2.2.x provided libosip2.so.3 and libosipparser2.so.3
It was parallel-installable with pkg libosip2*
Note the oddity, that v2.2.x of the lib uses a higher library version
than v3.0.x of the lib.
linphone was built with compat-libosip2-devel

Then an update of libosip2* to 3.1.x changed the SONAME.
Now it also provided libosip2.so.3 and libosipparser2.so.3
A conflict.

What to do? Block compat-libosip2* from Rawhide (!) as it cannot
be used anymore. Any dependency on libosip2*.so.3 would pull in the
3.0.x version instead of the compat pkg.

Comment 4 Bug Zapper 2008-11-26 02:30:23 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 5 Michael Schwendt 2008-12-23 23:19:19 UTC
Rawhide: This is about Rawhide (and older).

Still reproducible.

Would you please request releng to block this from Rawhide?

Comment 6 Michael Schwendt 2009-03-06 12:46:21 UTC
Ping! Why is this not being dealt with?

Comment 7 seth vidal 2009-03-08 20:19:53 UTC
A couple of things:

shortest-package-name-wins is not entirely true anymore. However, in this case it is likely that the other one will continue to win.

Comment 8 Jeffrey C. Ollie 2009-03-08 20:49:30 UTC
compat-libosip2 has been declared dead and has been blocked from rawhide.


Note You need to log in before you can comment on or make changes to this bug.