Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453883 - TB57133dcb __init__.py:526:_getGroups:GroupsError: No Groups Available in any repository
Summary: TB57133dcb __init__.py:526:_getGroups:GroupsError: No Groups Available in any...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pirut
Version: 5.2
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: James Antill
QA Contact:
URL:
Whiteboard:
: 465799 510468 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-03 01:06 UTC by John Craig
Modified: 2013-03-12 20:15 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-12 20:15:14 UTC


Attachments (Terms of Use)
pirut error dump (deleted)
2008-12-11 14:38 UTC, Suresh
no flags Details

Description John Craig 2008-07-03 01:06:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b5) Gecko/2008042803 Red Hat/3.0b5-0.beta5.6.el5 Firefox/3.0b5

Description of problem:
Traceback (most recent call last):
  File "/usr/sbin/pirut", line 122, in _pageSwitch
    self.pageMap[num]()
  File "/usr/sbin/pirut", line 327, in _showBrowse
    grpsel.doRefresh()
  File "/usr/lib/python2.4/site-packages/pirut/GroupSelector.py", line 523, in doRefresh
    if len(self.ayum.comps.categories) == 0:
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 553, in <lambda>
    comps = property(fget=lambda self: self._getGroups(),
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 526, in _getGroups
    raise Errors.GroupsError, 'No Groups Available in any repository'
GroupsError: No Groups Available in any repository

Local variables in innermost frame:
self: <__main__.PackageManager object at 0x1ef70110>
reposWithGroups: []
overwrite: False


Version-Release number of selected component (if applicable):
pirut-1.3.28-13.el5

How reproducible:
Always


Steps to Reproduce:
1. (as root) Open Applications > Add/Remove Software
2. Uncheck something to remove it
3. Apply (says successful before crash)

Actual Results:
Unhandled exception as above; program exits.

Expected Results:
Presumably, should have redisplayed the list of loaded software.

Additional info:
Configured for software development, mainly.

Comment 1 James Antill 2008-10-06 15:06:45 UTC
*** Bug 465799 has been marked as a duplicate of this bug. ***

Comment 2 Suresh 2008-12-11 14:38:22 UTC
Created attachment 326622 [details]
pirut error dump

Comment 3 James Antill 2009-07-09 13:58:25 UTC
*** Bug 510468 has been marked as a duplicate of this bug. ***

Comment 4 James Antill 2013-03-12 20:15:14 UTC
I believe the packaging GUI in RHEL-6 handles not having any groups, although it is a very unusual setup.


This request was evaluated by Red Hat Engineering for inclusion in a Red 
Hat Enterprise Linux maintenance release.

Red Hat does not currently plan to provide this change in a Red Hat 
Enterprise Linux update release for currently deployed products.

With the goal of minimizing risk of change for deployed systems, and in 
response to customer and partner requirements, Red Hat takes a 
conservative approach when evaluating enhancements for inclusion in 
maintenance updates for currently deployed products. The primary 
objectives of update releases are to enable new hardware platform 
support and to resolve critical defects.


Note You need to log in before you can comment on or make changes to this bug.