Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453882 - WPA Supplicant fails on kernel 2.6.25.9-76 with b43 driver
Summary: WPA Supplicant fails on kernel 2.6.25.9-76 with b43 driver
Keywords:
Status: CLOSED DUPLICATE of bug 453390
Alias: None
Product: Fedora
Classification: Fedora
Component: wpa_supplicant
Version: 9
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-03 01:06 UTC by Ryan Farmer
Modified: 2008-07-07 16:17 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-07 16:17:48 UTC


Attachments (Terms of Use)
Clip of network related log entries from /var/log/messages (deleted)
2008-07-03 01:06 UTC, Ryan Farmer
no flags Details
/var/log/messages (deleted)
2008-07-03 19:28 UTC, Phil Barnes
no flags Details
Dmesg output after turning on Wireless until fail of association (deleted)
2008-07-04 00:21 UTC, Philipp Fehre
no flags Details
Messages output from connection until fail (deleted)
2008-07-04 00:21 UTC, Philipp Fehre
no flags Details

Description Ryan Farmer 2008-07-03 01:06:04 UTC
Description of problem:

After updating to kernel 2.6.25.9-76, my Broadcom 4318 wireless chipset will no
longer authenticate with WPA protected networks.

How reproducible: Upgrade to kernel 2.6.25.9-76, use WPA Suppicant 0.6.3-6, use
b43 driver and firmware.

Steps to Reproduce:

1. Try to connect to any WPA protected network.
  
Actual results:

Connection fails at point of authentication.

Expected results:

Working connection.

Additional info:

Using 128-bit WEP, I am able to authenticate with the router, although this is a
nasty workaround it beats nothing, if you use this work around I suggest
creating a MAC Address whitelist on your router to bolster your network
security, and disabling wireless administration of the router.

I've created an attachment that I've clipped from /var/log/messages with related
information to this problem.

Comment 1 Ryan Farmer 2008-07-03 01:06:04 UTC
Created attachment 310871 [details]
Clip of network related log entries from /var/log/messages

Comment 2 Phil Barnes 2008-07-03 19:28:50 UTC
Created attachment 310955 [details]
/var/log/messages

Messages file filtered on NetworkManager, involves a few attempts to connect
before shutdown.

Comment 3 Phil Barnes 2008-07-03 19:32:57 UTC
It also breaks iwl3945. See my previous submission. 

Sorry I didn't realise creating an attachment would submit.

Comment 4 Philipp Fehre 2008-07-04 00:21:11 UTC
Created attachment 310968 [details]
Dmesg output after turning on Wireless until fail of association

Comment 5 Philipp Fehre 2008-07-04 00:21:48 UTC
Created attachment 310969 [details]
Messages output from connection until fail

Comment 6 Philipp Fehre 2008-07-04 00:23:42 UTC
Comment on attachment 310968 [details]
Dmesg output after turning on Wireless until fail of association

Same problem here on iwl3945 and b43 as well (own both cards) using Network
Manager as well as wpa_supplicant directly, first occurence after Kernel update

Comment 7 Philipp Fehre 2008-07-04 09:47:28 UTC
Seems to be a Kernel Problem, using the Kernel 2.6.25.6-55.fc9.i686 everything
works fine. 

Comment 8 Mark P. 2008-07-05 19:58:20 UTC
Here the same. I have a ASUS 167G. With Kernel 2.6.25.6-55.fc9.i686 it works fine.

Comment 9 Yanko Kaneti 2008-07-06 15:36:46 UTC
duplicate of bug 453390

Comment 10 Dan Williams 2008-07-07 16:17:48 UTC
yeah, it's kernel issues not the supplicant or NM.  Thanks for the dupe research!

*** This bug has been marked as a duplicate of 453390 ***


Note You need to log in before you can comment on or make changes to this bug.