Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453864 - Latest kernel/wireless updates breaks WPA(-PSK?)
Summary: Latest kernel/wireless updates breaks WPA(-PSK?)
Status: CLOSED DUPLICATE of bug 453390
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 9
Hardware: i686
OS: Linux
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2008-07-02 22:34 UTC by Stefan Becker
Modified: 2008-07-03 14:02 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2008-07-03 14:02:00 UTC

Attachments (Terms of Use)
wpa_supplicant debugging logfile from kernel- (OK) (deleted)
2008-07-02 22:36 UTC, Stefan Becker
no flags Details
wpa_supplicant debugging logfile from kernel- (BROKEN) (deleted)
2008-07-02 22:40 UTC, Stefan Becker
no flags Details

Description Stefan Becker 2008-07-02 22:34:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061712 Fedora/3.0-1.fc9 Firefox/3.0

Description of problem:
With the following kernels I can connect without problems using either the Intel 3945 in the laptop or an Atheros-based PCMCIA card:

 kernel-  (officially released)
 kernel-  (last internal kernel on koji before wireless updates)

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. boot into
2. login

Actual Results:
See NetworkManager trying to connect (LED blinks) but never completes the connection until timeout.

Expected Results:
NetworkManager can create WLAN WPA connection

Additional info:
I tried by hand with

  # service NetworkManager stop
  # wpa_supplicant -i wlan0 -c wpa_supplicant.conf -dd

I'll attach the OK/error log files.

Comment 1 Stefan Becker 2008-07-02 22:36:16 UTC
Created attachment 310863 [details]
wpa_supplicant debugging logfile from kernel- (OK)

Comment 2 Stefan Becker 2008-07-02 22:40:18 UTC
Created attachment 310865 [details]
wpa_supplicant debugging logfile from kernel- (BROKEN)

When you compare the OK to the BROKEN log file you see that everything works up
to here:


In the error case it never seems to receive the group ACK from the base

Comment 3 Stefan Becker 2008-07-02 22:41:50 UTC
I also  tried the latest kernel on Koji


which has even more wireless updates from upstream: still broken :-(

Comment 4 William Lovaton 2008-07-03 02:22:29 UTC
Yeah, me too  =(

Booting I can't connect to my wireless network.  Booting back with works fine as expected.

I am using an iwl3945 NIC.

Connecting to not protected networks works fine with both kernels, the problem
seems to be with the ones that are protected.

Comment 5 Ryan Farmer 2008-07-03 03:19:48 UTC
I think this may be the same bug as #453882 which I posted earlier.

Note that WEP still works, so if you live in an area where you doubt your in
range of anyone who knows how to crack WEP, you could use that, and then disable
remote management of your router along with MAC address filters as a workaround
until a new version of wpa supplicant is here.

Comment 6 Stefan Becker 2008-07-03 05:47:00 UTC
Latest kernel from koji


is still broken.

I also installed the only kernel between -72 (OK) and -76 (broken) from koji


It is also broken. That limits the culprit down to

<>  (-73)


<> (-74)

Looking at the changes I would put my money on one of those from -73:

Harvey Harrison (11):
      mac80211: add helpers for frame control testing
      mac80211: remove ieee80211_get_morefrag
      mac80211: make ieee80211_get_hdrlen_from_skb return unsigned
      mac80211: add utility function to get header length
      mac80211: wpa.c use new access helpers
      mac80211: use new helpers in util.c - ieee80211_get_bssid()
      mac80211: wme.c use new helpers
      mac80211: rx.c use new helpers
      mac80211: tkip.c consolidate tkip IV writing in helper
      mac80211: tkip.c fold ieee80211_gen_rc4key into its one caller
      mac80211: tkip.c use a local struct tkip_ctx in ieee80211_get_tkip_key

Comment 7 John W. Linville 2008-07-03 14:02:00 UTC

*** This bug has been marked as a duplicate of 453390 ***

Note You need to log in before you can comment on or make changes to this bug.