Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453859 - Eclipse mylyn doesn't work with the new testing bugzilla
Summary: Eclipse mylyn doesn't work with the new testing bugzilla
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Bugzilla
Classification: Community
Component: WebService
Version: devel
Hardware: All
OS: Linux
low
low vote
Target Milestone: ---
Assignee: PnT DevOps Devs
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-02 22:25 UTC by Matěj Cepl
Modified: 2013-06-24 02:22 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-11-06 19:38:29 UTC


Attachments (Terms of Use)
mylyn bug display (deleted)
2008-07-02 22:25 UTC, Matěj Cepl
no flags Details
Eclipse error log (deleted)
2008-07-02 22:26 UTC, Matěj Cepl
no flags Details
screenshot of the error dialog (deleted)
2008-07-03 12:24 UTC, Matěj Cepl
no flags Details


Links
System ID Priority Status Summary Last Updated
Eclipse Project 239435 None None None Never

Description Matěj Cepl 2008-07-02 22:25:35 UTC
Description of problem:
Cannot get tasks from the new testing bugzilla using Eclipse bugzilla mylyn
plugin from Ganymede (all jars, Ganymede has not been packaged yet for F9). When
using my own query
https://bz-web2-test.devel.redhat.com/buglist.cgi?cmdtype=runnamed&namedcmd=XGL%20NEW
I get just one bug (which is correct), but I cannot download the bug to the Task
List.

Version-Release number of selected component (if applicable):
Eclipse Version: 3.4.0, Build id: I20080617-2000
Mylyn Bugzilla Connector: 3.0.0.v20080619-1
(all from the upsteram jars)

How reproducible:
Unfortunately looks like 100% (tried four times)

Steps to Reproduce:
1.create a query from bugzilla saved queries
2.actualize all queries in mylyn
3.try to open the bug which is on the new list
  
Actual results:
see screenshot

Expected results:


Additional info:
-- Error Details --
Date: Thu Jul 03 00:05:47 CEST 2008
Message: Synchronization failed
Severity: Error
Plugin: org.eclipse.mylyn.tasks.core
Session Data:
eclipse.buildId=I20080617-2000
java.version=1.6.0
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=cs_CZ
Command-line arguments:  -os linux -ws gtk -arch x86


Exception Stack Trace:
java.lang.NullPointerException
at
org.eclipse.mylyn.internal.bugzilla.core.BugzillaClient$2.accept(BugzillaClient.java:1334)
at
org.eclipse.mylyn.internal.bugzilla.core.SaxMultiBugReportContentHandler.endElement(SaxMultiBugReportContentHandler.java:327)
at
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.endElement(Unknown
Source)
at
com.sun.org.apache.xerces.internal.impl.dtd.XMLNSDTDValidator.endNamespaceScope(Unknown
Source)
at
com.sun.org.apache.xerces.internal.impl.dtd.XMLDTDValidator.handleEndElement(Unknown
Source)
at
com.sun.org.apache.xerces.internal.impl.dtd.XMLDTDValidator.endElement(Unknown
Source)
at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanEndElement(Unknown
Source)
at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(Unknown
Source)
at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(Unknown
Source)
at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(Unknown
Source)
at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown
Source)
at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown
Source)
at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown
Source)
at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(Unknown Source)
at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(Unknown
Source)
at
org.eclipse.mylyn.internal.bugzilla.core.AbstractReportFactory.collectResults(AbstractReportFactory.java:118)
at
org.eclipse.mylyn.internal.bugzilla.core.MultiBugReportFactory.populateReport(MultiBugReportFactory.java:40)
at
org.eclipse.mylyn.internal.bugzilla.core.BugzillaClient.getTaskData(BugzillaClient.java:1343)
at
org.eclipse.mylyn.internal.bugzilla.core.BugzillaTaskDataHandler.getMultiTaskData(BugzillaTaskDataHandler.java:204)
at
org.eclipse.mylyn.internal.tasks.core.sync.SynchronizeTasksJob.synchronizeTasks(SynchronizeTasksJob.java:330)
at
org.eclipse.mylyn.internal.tasks.core.sync.SynchronizeTasksJob.runInternal(SynchronizeTasksJob.java:196)
at
org.eclipse.mylyn.internal.tasks.core.sync.SynchronizeTasksJob.run(SynchronizeTasksJob.java:149)
at
org.eclipse.mylyn.internal.tasks.core.sync.SynchronizeTasksJob.run(SynchronizeTasksJob.java:128)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

Comment 1 Matěj Cepl 2008-07-02 22:25:35 UTC
Created attachment 310861 [details]
mylyn bug display

Comment 2 Matěj Cepl 2008-07-02 22:26:22 UTC
Created attachment 310862 [details]
Eclipse error log

Comment 3 Matěj Cepl 2008-07-02 22:27:44 UTC
I am not sure, whether this is actually Eclipse/Mylyn bug or Bugzilla devel bug,
but because this verison of eclipse is not part of any Fedora, I started with
Bugzilla.

Comment 4 Matěj Cepl 2008-07-02 22:32:53 UTC
mcepl: overholt: should I switch
https://bugzilla.redhat.com/show_bug.cgi?id=453859 to Eclipse (although this is
using Ganymede)?
overholt: mcepl, eclipse.org, maybe?
mcepl: well, or if this is bug in our (not yet public) bugzilla?
overholt: mcepl, it's not public?
mcepl: actually, ... I don't know 
mcepl: take a look at the URL in the bug
overholt: mcepl, well, find out if it's public.  if it is, ask the mylyn guys
upstream.  if it's not, I can take a look.  just email me.
overholt: mcepl, I've gotta run.  ttyl.
mcepl: (and partner-bugzilla is down in the moment)
 - overholt has left the room

Comment 5 Noura El hawary 2008-07-03 01:34:38 UTC
bz-web2-test.devel.redhat.com is not public , Please use
partner-bugzilla.redhat.com for your testing as it is the the public site it
should be up and running now, and let us know if you still have any troubles.

Noura

Comment 6 Matěj Cepl 2008-07-03 12:24:41 UTC
Created attachment 310917 [details]
screenshot of the error dialog

OK, let's split this into two bugs -- one will stay here and other will be on
bugs.eclipse.org. For this one I would have that when synchronizing partners*
bugzilla, I get attached error message and (I think, Error Log Viewer is still
somehow confusing to me) this error:

eclipse.buildId=I20080617-2000
java.version=1.6.0
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=cs_CZ
Command-line arguments:  -os linux -ws gtk -arch x86


Error
Thu Jul 03 14:12:27 CEST 2008
Synchronization failed

java.lang.NullPointerException
at
org.eclipse.mylyn.internal.bugzilla.core.BugzillaClient$2.accept(BugzillaClient.java:1334)

at
org.eclipse.mylyn.internal.bugzilla.core.SaxMultiBugReportContentHandler.endElement(SaxMultiBugReportContentHandler.java:327)

at
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.endElement(Unknown
Source)
at
com.sun.org.apache.xerces.internal.impl.dtd.XMLNSDTDValidator.endNamespaceScope(Unknown
Source)
at
com.sun.org.apache.xerces.internal.impl.dtd.XMLDTDValidator.handleEndElement(Unknown
Source)
at
com.sun.org.apache.xerces.internal.impl.dtd.XMLDTDValidator.endElement(Unknown
Source)
at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanEndElement(Unknown
Source)
at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(Unknown
Source)
at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(Unknown
Source)
at
com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(Unknown
Source)
at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown
Source)
at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown
Source)
at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown
Source)
at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(Unknown Source)
at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(Unknown
Source)
at
org.eclipse.mylyn.internal.bugzilla.core.AbstractReportFactory.collectResults(AbstractReportFactory.java:118)

at
org.eclipse.mylyn.internal.bugzilla.core.MultiBugReportFactory.populateReport(MultiBugReportFactory.java:40)

at
org.eclipse.mylyn.internal.bugzilla.core.BugzillaClient.getTaskData(BugzillaClient.java:1343)

at
org.eclipse.mylyn.internal.bugzilla.core.BugzillaTaskDataHandler.getMultiTaskData(BugzillaTaskDataHandler.java:204)

at
org.eclipse.mylyn.internal.tasks.core.sync.SynchronizeTasksJob.synchronizeTasks(SynchronizeTasksJob.java:330)

at
org.eclipse.mylyn.internal.tasks.core.sync.SynchronizeTasksJob.runInternal(SynchronizeTasksJob.java:196)

at
org.eclipse.mylyn.internal.tasks.core.sync.SynchronizeTasksJob.run(SynchronizeTasksJob.java:149)

at
org.eclipse.mylyn.internal.tasks.core.sync.SynchronizeTasksJob.run(SynchronizeTasksJob.java:134)

at
org.eclipse.mylyn.internal.tasks.core.sync.SynchronizeQueriesJob.run(SynchronizeQueriesJob.java:248)

at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

Comment 7 Matěj Cepl 2008-07-03 12:25:26 UTC
The rest will go probably to the upstream bugzilla (not able to change a status
of the bug)

Comment 8 Matěj Cepl 2008-07-03 12:51:39 UTC
Upstream bug is https://bugs.eclipse.org/bugs/show_bug.cgi?id=239435

Comment 9 Matěj Cepl 2008-09-04 21:02:41 UTC
I think this is now working with the final version of RH Bugzilla. Closing.

Comment 10 Alexander Kurtakov 2008-11-06 19:38:29 UTC
Really closing the bug.
It is working.


Note You need to log in before you can comment on or make changes to this bug.