Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453856 - Review Request: globus-gsi-cert-utils - Globus Toolkit - Globus GSI Cert Utils Library
Summary: Review Request: globus-gsi-cert-utils - Globus Toolkit - Globus GSI Cert Util...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Thomas Sailer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: gpt 453848 453850 453851 453853 453855
Blocks: globus 453858 453861 453862 453865 467237 467239
TreeView+ depends on / blocked
 
Reported: 2008-07-02 22:18 UTC by Mattias Ellert
Modified: 2009-05-14 02:56 UTC (History)
3 users (show)

Fixed In Version: 5.5-1.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-05-06 23:23:17 UTC
t.sailer: fedora-review+
kevin: fedora-cvs+


Attachments (Terms of Use)

Description Mattias Ellert 2008-07-02 22:18:28 UTC
Spec URL: http://www.grid.tsl.uu.se/repos/globus/fedora/9/info/globus-gsi-cert-utils.spec
SRPM URL: http://www.grid.tsl.uu.se/repos/globus/fedora/9/src/SRPMS/globus-gsi-cert-utils-2.11-0.1.fc9.src.rpm
Description :
The Globus Toolkit is an open source software toolkit used for
building Grid systems and applications. It is being developed by the
Globus Alliance and many others all over the world. A growing number
of projects and companies are using the Globus Toolkit to unlock the
potential of grids for their cause.

The globus-gsi-cert-utils package contains:
Globus GSI Cert Utils Library

BuildRequires:  gpt
BuildRequires:  libtool
BuildRequires:  globus-common-devel >= 3
BuildRequires:  globus-openssl-module-devel >= 0
BuildRequires:  globus-gsi-openssl-error-devel >= 0
BuildRequires:  globus-openssl-devel >= 1
BuildRequires:  globus-core-devel >= 4

Comment 2 Mattias Ellert 2009-01-06 00:48:00 UTC
This package was updated due to the renaming of the GPT package.

SRPM: http://www.grid.tsl.uu.se/repos/globus/fedora/10/src/SRPMS/globus-gsi-cert-utils-5.0-0.3.fc10.src.rpm

SPEC: http://www.grid.tsl.uu.se/repos/globus/info/globus-gsi-cert-utils.spec

Comment 3 Mattias Ellert 2009-03-15 23:59:02 UTC
New version
- Added s390x as 64 bit arch
- Update to upstream update version
- Adapt to changes in the globus-core package

http://www.grid.tsl.uu.se/repos/globus/fedora/10/src/SRPMS/globus-gsi-cert-utils-5.5-0.5.fc10.src.rpm
http://www.grid.tsl.uu.se/repos/globus/info/globus-gsi-cert-utils.spec

Comment 4 Mattias Ellert 2009-04-17 13:44:09 UTC
Package updated due to new packaging guidelines
- Change defines to globals
- Remove explicit requires on library packages

http://www.grid.tsl.uu.se/repos/globus/info/new/globus-gsi-cert-utils-5.5-1.fc10.src.rpm
http://www.grid.tsl.uu.se/repos/globus/info/new/globus-gsi-cert-utils.spec

Draft packaging guidelines for Globus packages are now available:
http://fedoraproject.org/wiki/PackagingDrafts/Globus

Comment 5 Thomas Sailer 2009-04-29 10:19:36 UTC
Sources match upstream:
48987f39031ac79949a9b0913aa42c67  ORIG/globus_gsi_cert_utils-5.5.tar.gz
48987f39031ac79949a9b0913aa42c67  SOURCES/globus_gsi_cert_utils-5.5.tar.gz

$ rpmlint globus-gsi-cert-utils*.rpm globus-gsi-cert-utils.spec
globus-gsi-cert-utils.x86_64: W: no-documentation
globus-gsi-cert-utils-devel.x86_64: W: no-documentation
globus-gsi-cert-utils-progs.x86_64: W: no-documentation
5 packages and 1 specfiles checked; 0 errors, 3 warnings.

Scratch build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1328252

Comment 6 Thomas Sailer 2009-04-29 10:25:10 UTC
Fedora review globus-gsi-cert-utils-5.5-1.fc10.src.rpm 2009-04-29

+ OK
! needs attention

+ rpmlint output
  See above; the "no documentation" warning can be ignored. Source Tarball does not contain a license file
+ Package is named according to Fedora Package Naming Guidelines
+ Specfile name matches the package base name
+ Package follows the Fedora packaging guidelines
+ License meets guidelines and is acceptable to Fedora
  ASL 2.0
+ License matches the actual package license
n/a The package contains the license file
  none shipped by upstream tarball
+ Spec file is written in American English
+ Spec file is legible
+ Upstream sources match sources in the srpm
  48987f39031ac79949a9b0913aa42c67  ORIG/globus_gsi_cert_utils-5.5.tar.gz
  48987f39031ac79949a9b0913aa42c67  SOURCES/globus_gsi_cert_utils-5.5.tar.gz
+ Package scratch-builds
n/a ExcludeArch bugs filed
+ BuildRequires list all build dependencies
n/a %find_lang instead of %{_datadir}/locale/*
+ binary RPM with shared library files must call ldconfig in %post and
%postun
+ Does not use Prefix: /usr
+ Package owns all directories it creates
+ No duplicate files in %files
+ %files has %defattr
+ %clean contains rm -rf $RPM_BUILD_ROOT
+ Consistent use of macros
+ Package must contain code or permissible content
+ Large documentation files should go in -doc subpackage
n/a Files marked %doc should not affect package
+ Header files should be in -devel
n/a Static libraries should be in -static
+ Packages containing pkgconfig (.pc) files need 'Requires: pkgconfig'
  indirectly, via R: globus-core
+ libfoo.so must go in -devel
+ -devel must require the fully versioned base
+ Packages should not contain libtool .la files
n/a Packages containing GUI apps must include %{name}.desktop file
+ Packages must not own files or directories owned by other packages
+ %install begins with rm -rf $RPM_BUILD_ROOT
+ Filenames must be valid UTF-8

APPROVED by sailer.

Comment 7 Mattias Ellert 2009-04-29 10:43:00 UTC
Thank you for the review.


New Package CVS Request
=======================
Package Name: globus-gsi-cert-utils
Short Description: Globus Toolkit - Globus GSI Cert Utils Library
Owners: ellert
Branches: F-9 F-10 F-11 EL-4 EL-5
InitialCC:

Comment 8 Kevin Fenzi 2009-04-30 04:38:40 UTC
cvs done.

Comment 9 Mattias Ellert 2009-04-30 09:41:20 UTC
Package available in devel.

Comment 10 Fedora Update System 2009-05-04 07:28:34 UTC
globus-gsi-cert-utils-5.5-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/globus-gsi-cert-utils-5.5-1.fc10

Comment 11 Fedora Update System 2009-05-04 07:28:41 UTC
globus-gsi-cert-utils-5.5-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/globus-gsi-cert-utils-5.5-1.fc9

Comment 12 Fedora Update System 2009-05-06 23:23:12 UTC
globus-gsi-cert-utils-5.5-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2009-05-06 23:30:34 UTC
globus-gsi-cert-utils-5.5-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2009-05-12 22:48:02 UTC
globus-gsi-cert-utils-5.5-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/globus-gsi-cert-utils-5.5-1.fc11

Comment 15 Fedora Update System 2009-05-14 02:56:12 UTC
globus-gsi-cert-utils-5.5-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.