Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453829 - bindings file not getting updated after LUN removed from zfcp.conf
Summary: bindings file not getting updated after LUN removed from zfcp.conf
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: device-mapper-multipath
Version: 5.2
Hardware: s390x
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: LVM and device-mapper development team
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-02 19:56 UTC by Betsie Spann
Modified: 2010-01-12 02:43 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-03 15:13:11 UTC
Target Upstream Version:


Attachments (Terms of Use)
cat of zfcp.conf, bindings file, output of multipath -ll (deleted)
2008-07-02 19:56 UTC, Betsie Spann
no flags Details
command log (deleted)
2008-07-02 20:47 UTC, Brad Hinson
no flags Details

Description Betsie Spann 2008-07-02 19:56:21 UTC
Description of problem: Running 5.2 multipath component on RHEL 5.0. Removed a 
LUN from /etc/zfcp.conf, added another LUN to the file and rebooted 
but /etc/multipath_bindings is not correct.   It has the new LUN as mpath7 but 
still contains an entry for the removed LUN, mpath6. 


Version-Release number of selected component (if applicable):
Linux sl55uvsigns 2.6.18-8.1.8.el5 #1 SMP Mon Jun 25 17:06:15 EDT 2007 s390x 
s390x s390x GNU/Linux  (RHEL 5.0)
device-mapper-multipath-0.4.7-17.el5    (RHEL 5.2 component)
kpartx-0.4.7-17.el5
How reproducible:
at will

Steps to Reproduce:
1. update /etc/zfcp.conf
2. multipath -F, mulitpath   or reboot
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Betsie Spann 2008-07-02 19:56:21 UTC
Created attachment 310849 [details]
cat of zfcp.conf, bindings file, output of multipath -ll

Comment 2 Betsie Spann 2008-07-02 20:09:33 UTC
The new LUN (mpath7) has one partition:
/dev/sdg1               1        9792    78654208+  83  Linux

but it doesn't show up in /dev/mpath

/dev/mpath/mpath0   [      536.94 GB]
  /dev/mpath/mpath1   [      536.94 GB]
  /dev/mpath/mpath2   [      536.94 GB]
  /dev/mpath/mpath3   [      536.94 GB]
  /dev/mpath/mpath4   [      100.02 GB]
  /dev/mpath/mpath5   [      100.02 GB]
  /dev/mpath/mpath7   [       75.01 GB]
  /dev/mpath/mpath5p1 [      100.01 GB] LVM physical volume
  /dev/mpath/mpath2p1 [      536.93 GB] LVM physical volume
  /dev/mpath/mpath0p1 [      536.93 GB] LVM physical volume
  /dev/mpath/mpath3p1 [      536.93 GB] LVM physical volume
  /dev/mpath/mpath1p1 [      536.93 GB] LVM physical volume
  /dev/mpath/mpath4p1 [      100.02 GB] LVM physical volume
  2 disks
  10 partitions
  0 LVM physical volume whole disks
  7 LVM physical volumes
[root@sl55uvsigns ~]# pvcreate /dev/mapper/mpath7p1
  Device /dev/mapper/mpath7p1 not found (or ignored by filtering).
[root@sl55uvsigns ~]# ls /dev/mpath
mpath0    mpath1    mpath2    mpath3    mpath4    mpath5    mpath7
mpath0p1  mpath1p1  mpath2p1  mpath3p1  mpath4p1  mpath5p1

I cannot create the pv on the new LUN (mpath7)

Comment 3 Brad Hinson 2008-07-02 20:47:48 UTC
Created attachment 310853 [details]
command log

Also reproducible on stock 5.2 system.	Attached log shows
/var/lib/multipath/bindings is not updated when the LUN is removed.  It is,
however, update when the LUN is added (not shown in this log).

Comment 4 Bryn M. Reeves 2008-07-03 10:13:15 UTC
This is by design; multipath only adds aliases to the bindings file; it never
removes them (see libmultipath/alias.c). Otherwise as LUNs appear/disappear
(say, due to transient configuration changes/outages) the mpathN aliases get
re-used in unpredictable ways.

You can manualls remove aliases for LUNs that have been permanently removed from
the bindings file, or if you're frequently adding/removing LUNs you may prefer
to use the "alias" directive in multipath.conf to control the WWID to name mappings.

Maybe multipath could use an option to explicitly remove an alias from the
bindings file but doing so automatically would be problematic in a lot of cases.



Note You need to log in before you can comment on or make changes to this bug.