Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453827 - Can't connect to wireless with NetworkManager
Summary: Can't connect to wireless with NetworkManager
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 8
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 455150 455155 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-02 19:54 UTC by Mary Ellen Foster
Modified: 2008-08-02 23:40 UTC (History)
4 users (show)

Fixed In Version: 2.6.25.10-47.fc8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-15 12:16:08 UTC


Attachments (Terms of Use)

Description Mary Ellen Foster 2008-07-02 19:54:47 UTC
Description of problem:
With kernel-2.6.25.9-40.fc8, I'm never able to connect to my (WPA-enabled)
access point with NetworkManager. It spins for a while and then prompts me again
for the WPA passphrase. Everything works great with kernel-2.6.25.6-27.fc8, though.

I use iwl3945 wireless.

Version-Release number of selected component (if applicable):
kernel-2.6.25.9-40.fc8

How reproducible:
Every time

Steps to Reproduce:
1. Select access point from NetworkManager menu
2. Enter the Gnome keyring password
  
Actual results:
Spins for a while, then times out and prompts again for the WPA passphrase. If I
enter the correct phrase, it does the same thing again.

Expected results:
Connecting to the wireless

Additional info:
I can attach logs if necessary

Comment 1 John W. Linville 2008-07-02 20:49:59 UTC
This is probably related to bug 453390, just in F8 instead.  Since they aren't
getting wireless updates on the same schedule, that may help to narrow down what
caused this issue...

Comment 2 Mary Ellen Foster 2008-07-03 09:00:52 UTC
It looks like this kernel was just pushed to F8 stable. I suppose the other
bug-fixes outweigh the WPA breakage ...

Comment 3 Kevin Kofler 2008-07-04 20:44:15 UTC
This is the exact same bug as bug 453390 for F9, the same broken hunk in 
linux-2.6-wireless-fixups.patch is also in F8 kernels >= 2.6.25.9-38.fc8.

Comment 4 John W. Linville 2008-07-04 21:02:30 UTC
Build with patch believe to fix this issue is here:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=54856

When it finishes, please try the resulting kernels.  Do they resolve the WPA
issue for you?

Comment 5 Fedora Update System 2008-07-08 14:27:37 UTC
kernel-2.6.25.10-47.fc8 has been submitted as an update for Fedora 8

Comment 6 Fedora Update System 2008-07-09 02:48:03 UTC
kernel-2.6.25.10-47.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-6200

Comment 7 John W. Linville 2008-07-14 13:24:27 UTC
*** Bug 455155 has been marked as a duplicate of this bug. ***

Comment 8 John W. Linville 2008-07-14 13:26:22 UTC
*** Bug 455150 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2008-07-15 12:16:02 UTC
kernel-2.6.25.10-47.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.