Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453823 - gpk-update-viewer crash on startup or running from PackageKit Update Applet
Summary: gpk-update-viewer crash on startup or running from PackageKit Update Applet
Keywords:
Status: CLOSED DUPLICATE of bug 452080
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-packagekit
Version: 9
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Robin Norwood
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-02 19:32 UTC by JanS
Modified: 2008-07-04 09:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-04 09:39:36 UTC


Attachments (Terms of Use)
gpk-update-viewer-bugreport (deleted)
2008-07-02 19:32 UTC, JanS
no flags Details
Output from gdb run --verbose (deleted)
2008-07-02 19:34 UTC, JanS
no flags Details

Description JanS 2008-07-02 19:32:45 UTC
Description of problem:
As a user, not in root console, I cannot run update process.
Every time I try to run gpk-update-viewer it crashes, not depending on how I run
it, is it from Main Menu or by clicking Show Updates in PackageKit Update Applet.

Version-Release number of selected component (if applicable):
gnome-packagekit.x86_64                  0.1.12-12.20080430.fc9
yum-packagekit.x86_64                    0.1.12-13.20080522.fc9

How reproducible:
65% times when I do updates on Fedora 9. Sometimes it works and prompts me for a
root password in window, but usualy not, it crashes before. All I can do is to
log as root and run "yum update" or gpk-update-viewer manually. 

Steps to Reproduce:
1. click on Show Updates in PackageKit Update Applet or use Main Menu >
Administration or type in terminal gpk-update-viewer
2. watch as small gray window entitled "Update System" shows up for a second
3. crash
  
Actual results:
After clicking on Show Updates in Applet small window appears and disappears.

Expected results:
After clicking on Show Updates in Applet updates are displayed. And one could
choose what to do than.

Additional info:
I am sending gpk-update-viewer-bugreport.txt in attachment

Comment 1 JanS 2008-07-02 19:32:45 UTC
Created attachment 310845 [details]
gpk-update-viewer-bugreport

Comment 2 JanS 2008-07-02 19:34:08 UTC
Created attachment 310846 [details]
Output from gdb run --verbose

Comment 3 Richard Hughes 2008-07-04 09:36:08 UTC
When you run it under gdb, can you please type "bt" when it crashes to get the
backtrace. Also, please install the debuginfo's for PolicyKit and
PolicyKit-gnome -- thanks.

Comment 4 Richard Hughes 2008-07-04 09:39:36 UTC

*** This bug has been marked as a duplicate of 452080 ***


Note You need to log in before you can comment on or make changes to this bug.