Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453813 - installer plays with partition ordering
Summary: installer plays with partition ordering
Keywords:
Status: CLOSED DUPLICATE of bug 410011
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-02 18:10 UTC by David Woodhouse
Modified: 2008-08-06 19:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-06 19:35:38 UTC


Attachments (Terms of Use)
screen shot (deleted)
2008-07-02 18:15 UTC, David Woodhouse
no flags Details

Description David Woodhouse 2008-07-02 18:10:27 UTC
I'm trying to set up a couple of disks in RAID1, each with a set of partitions.

I tried the 'clone disk' option, but the partitions on sdb ended up in a
_different_ order to those on sda.

I cloned it again to sdc, since I happened to have a third matching disk. That
seemed OK -- at least sdb matched sdc. But I'd forgotten to add a swap
partition. And now I've added swap, all three disks are different.

It would be useful if the installer gave us the option of _numbering_ partitions
as we want them. But getting them in the same order on each disk, when the set
of partitions is identical, would be nice. Getting three _different_ answers for
the same set of partitions is particularly impressive :)

I have four partitions on each disk, and I want them all to be primary
partitions. I'm a little surprised that it defaults to using an extended
partition when there are only four. When I edit a partition and select 'force to
be a primary partition', the installer seems to _forget_ that the partition in
question was already restricted to a certain disk, which I had set earlier while
trying to sort it out.

Comment 1 David Woodhouse 2008-07-02 18:15:02 UTC
Created attachment 310835 [details]
screen shot

Comment 2 David Woodhouse 2008-07-02 19:11:13 UTC
And now it's doing a RAID resync on the whole terabyte. While sitting at the
'install finished. you can reboot now' screen. Is that just a limitation of RAID?

Comment 3 Chris Lumens 2008-08-06 19:35:38 UTC

*** This bug has been marked as a duplicate of bug 410011 ***


Note You need to log in before you can comment on or make changes to this bug.