Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453808 - qc timeout probing TEAC DV-28E-V CD/DVD drive on SATA/PATA bridge
Summary: qc timeout probing TEAC DV-28E-V CD/DVD drive on SATA/PATA bridge
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.8
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: David Milburn
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On:
Blocks: 461304
TreeView+ depends on / blocked
 
Reported: 2008-07-02 17:14 UTC by Bryn M. Reeves
Modified: 2018-10-20 02:47 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-17 20:30:33 UTC


Attachments (Terms of Use)

Description Bryn M. Reeves 2008-07-02 17:14:22 UTC
Description of problem:
At boot and when attempting to access the CD/DVD drive the following messages
are logged:

   ata3.00: qc timeout (cmd 0xa0)
   ata3.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
   ata3.00: (BMDMA stat 0x25)
   ata3.00: cmd a0/01:00:00:00:00/00:00:00:00:00/a0 tag 0 cdb 0x43 data
   12 in res 51/20:03:00:00:00/00:00:00:00:00/a0 Emask 0x5 (timeout)
   ata3: port is slow to respond, please be patient (Status 0xd0)
   ata3: port failed to respond (30 secs, Status 0xd0)
   ata3: soft resetting port
   ata3.00: configured for UDMA/33
   ata3: EH complete

Drive identifies itself in /proc/scsi/scsi as:

   Host: scsi2 Channel: 00 Id: 00 Lun: 00
   Vendor: TEAC     Model: DV-28E-V         Rev: C.AB
   Type:   CD-ROM                           ANSI SCSI revision: 05


Version-Release number of selected component (if applicable):
2.6.9-67.EL, 2.6.9-67.0.4.EL

How reproducible:
100%

Steps to Reproduce:
1. Boot a system with the affected drive model attached to a SATA controller via
a PATA bridge
  
Actual results:
Above messages at boot time & as the system is running (presumably when
attempting to access the drive).

Expected results:
No messages at boot, drive works.

Additional info:
A similar problem was reported to the kernel.org bugzilla:

http://bugzilla.kernel.org/show_bug.cgi?id=10887

This involved the same drive model but attached directly to an IDE controller.
In that case the problem was avoided by increasing the retry count in
drivers/ide/ide-taskfile.c:wait_drive_not_busy() from 100 to 1000 (commit
f54feafa6d47d0aa1a96adefdc763b708b02f94f):

Author: Bartlomiej Zolnierkiewicz <bzolnier@gmail.com>
Date:   Fri Jun 20 20:53:33 2008 +0200

    ide: increase timeout in wait_drive_not_busy()
    
    Some ATAPI devices take longer than the current max timeout value to
    become ready (i.e. TEAC DV-W28ECW takes 6 ms) so increase the timeout
    value to 10 ms.
    
    This fixes kernel.org bugzilla bug #10887:
    http://bugzilla.kernel.org/show_bug.cgi?id=10887
    
    Reported-by: Masanari Iida <standby24x7@gmail.com>
    Signed-off-by: Bartlomiej Zolnierkiewicz <bzolnier@gmail.com>

Comment 2 Bryn M. Reeves 2008-07-21 12:18:59 UTC
Trying to get confirmation on whether increasing ata_probe_timeout actually
helped the problem. Have another report of this now - will ask the reporter to test.



Comment 6 RHEL Product and Program Management 2008-09-03 13:08:44 UTC
Updating PM score.


Note You need to log in before you can comment on or make changes to this bug.