Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453791 - Kernel 2.6.25.9-76.fc9.i686 breaks iwl3945 associations
Summary: Kernel 2.6.25.9-76.fc9.i686 breaks iwl3945 associations
Keywords:
Status: CLOSED DUPLICATE of bug 453390
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 9
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-02 15:09 UTC by Tim Becker
Modified: 2008-07-02 15:14 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-02 15:14:35 UTC


Attachments (Terms of Use)

Description Tim Becker 2008-07-02 15:09:39 UTC
Description of problem:
After updating to kernel 2.6.25.9-76.fc9.i686 the iwl3945 wireless driver will
no longer associate to wireless network with WPA2.  Wireless works fine in
2.6.25.6-55 kernel.

Version-Release number of selected component (if applicable):
kernel 2.6.25.9-76.fc9.i686

How reproducible:
100%

Steps to Reproduce:
1.Boot kernel 2.6.25.9-76
2.Wireless association fails 
3.
  
Actual results:
Wireless association fails

Expected results:
Wireless association succeeds 

Additional info:
messages output of failed association attempt:

Jul  2 06:56:22 barley NetworkManager: <info>  Activation (wlan0) starting
connection 'Auto < SSID here >'
Jul  2 06:56:22 barley NetworkManager: <info>  (wlan0): device state change: 3 -> 4
Jul  2 06:56:22 barley NetworkManager: <info>  Activation (wlan0) Stage 1 of 5
(Device Prepare) scheduled...
Jul  2 06:56:22 barley NetworkManager: <info>  Activation (wlan0) Stage 1 of 5
(Device Prepare) started...
Jul  2 06:56:22 barley NetworkManager: <info>  Activation (wlan0) Stage 2 of 5
(Device Configure) scheduled...
Jul  2 06:56:22 barley NetworkManager: <info>  Activation (wlan0) Stage 1 of 5
(Device Prepare) complete.
Jul  2 06:56:22 barley NetworkManager: <info>  Activation (wlan0) Stage 2 of 5
(Device Configure) starting...
Jul  2 06:56:22 barley NetworkManager: <info>  (wlan0): device state change: 4 -> 5
Jul  2 06:56:22 barley NetworkManager: <info>  Activation (wlan0/wireless):
access point 'Auto < SSID here >' has security, but secr
ets are required.
Jul  2 06:56:22 barley NetworkManager: <info>  (wlan0): device state change: 5 -> 6
Jul  2 06:56:22 barley NetworkManager: <info>  Activation (wlan0) Stage 2 of 5
(Device Configure) complete.
Jul  2 06:56:22 barley NetworkManager: Missing or invalid key management
Jul  2 06:56:22 barley NetworkManager: <info>  Activation (wlan0) Stage 1 of 5
(Device Prepare) scheduled...
Jul  2 06:56:22 barley NetworkManager: <info>  Activation (wlan0) Stage 1 of 5
(Device Prepare) started...
Jul  2 06:56:22 barley NetworkManager: <info>  (wlan0): device state change: 6 -> 4
Jul  2 06:56:22 barley NetworkManager: <info>  Activation (wlan0) Stage 2 of 5
(Device Configure) scheduled...
Jul  2 06:56:22 barley NetworkManager: <info>  Activation (wlan0) Stage 1 of 5
(Device Prepare) complete.
Jul  2 06:56:22 barley NetworkManager: <info>  Activation (wlan0) Stage 2 of 5
(Device Configure) starting...
Jul  2 06:56:22 barley NetworkManager: <info>  (wlan0): device state change: 4 -> 5
Jul  2 06:56:22 barley NetworkManager: <info>  Activation (wlan0/wireless):
connection 'Auto < SSID here >' has security, and secret
s exist.  No new secrets needed.
Jul  2 06:56:22 barley NetworkManager: <info>  Config: added 'ssid' value
'sixdegreesBOI'
Jul  2 06:56:22 barley NetworkManager: <info>  Config: added 'scan_ssid' value '1'
Jul  2 06:56:22 barley NetworkManager: <info>  Config: added 'key_mgmt' value
'WPA-PSK'
Jul  2 06:56:22 barley NetworkManager: <info>  Config: added 'psk' value '<omitted>'
Jul  2 06:56:22 barley NetworkManager: <info>  Config: added 'proto' value 'WPA RSN'
Jul  2 06:56:22 barley NetworkManager: <info>  Config: added 'pairwise' value
'TKIP CCMP'
Jul  2 06:56:22 barley NetworkManager: <info>  Config: added 'group' value
'WEP40 WEP104 TKIP CCMP'
Jul  2 06:56:22 barley NetworkManager: <info>  Activation (wlan0) Stage 2 of 5
(Device Configure) complete.
Jul  2 06:56:22 barley NetworkManager: <info>  Config: set interface ap_scan to 1
Jul  2 06:56:22 barley NetworkManager: <info>  (wlan0): supplicant connection
state change: 1 -> 2
Jul  2 06:56:23 barley NetworkManager: <info>  (wlan0): supplicant connection
state change: 2 -> 3
Jul  2 06:56:23 barley kernel: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Jul  2 06:56:23 barley NetworkManager: <info>  (wlan0): supplicant connection
state change: 3 -> 4
Jul  2 06:56:24 barley NetworkManager: <info>  (wlan0): supplicant connection
state change: 4 -> 5
Jul  2 06:56:24 barley NetworkManager: <info>  (wlan0): supplicant connection
state change: 5 -> 6
Jul  2 06:56:25 barley avahi-daemon[2393]: Registering new address record for
fe80::213:2ff:fe20:f6a6 on wlan0.*.
Jul  2 06:56:28 barley NetworkManager: <info>  (wlan0): supplicant connection
state change: 6 -> 0
Jul  2 06:56:28 barley NetworkManager: <info>  (wlan0): supplicant connection
state change: 0 -> 2
Jul  2 06:56:29 barley NetworkManager: <info>  (wlan0): supplicant connection
state change: 2 -> 4
Jul  2 06:56:29 barley NetworkManager: <info>  (wlan0): supplicant connection
state change: 4 -> 5
Jul  2 06:56:29 barley NetworkManager: <info>  (wlan0): supplicant connection
state change: 5 -> 6
Jul  2 06:56:33 barley NetworkManager: <info>  (wlan0): supplicant connection
state change: 6 -> 0
Jul  2 06:56:33 barley NetworkManager: <info>  (wlan0): supplicant connection
state change: 0 -> 2
Jul  2 06:56:34 barley NetworkManager: <info>  (wlan0): supplicant connection
state change: 2 -> 4
Jul  2 06:56:34 barley NetworkManager: <info>  (wlan0): supplicant connection
state change: 4 -> 5
Jul  2 06:56:34 barley NetworkManager: <info>  (wlan0): supplicant connection
state change: 5 -> 6
Jul  2 06:56:38 barley NetworkManager: <info>  (wlan0): supplicant connection
state change: 6 -> 0
Jul  2 06:56:38 barley NetworkManager: <info>  (wlan0): supplicant connection
state change: 0 -> 2
Jul  2 06:56:39 barley NetworkManager: <info>  (wlan0): supplicant connection
state change: 2 -> 4
Jul  2 06:56:39 barley NetworkManager: <info>  (wlan0): supplicant connection
state change: 4 -> 5
Jul  2 06:56:39 barley NetworkManager: <info>  (wlan0): supplicant connection
state change: 5 -> 6
Jul  2 06:56:43 barley NetworkManager: <info>  wlan0: link timed out.
Jul  2 06:56:43 barley NetworkManager: <info>  (wlan0): supplicant connection
state change: 6 -> 0
Jul  2 06:56:43 barley NetworkManager: <info>  (wlan0): supplicant connection
state change: 0 -> 4
Jul  2 06:56:43 barley NetworkManager: <info>  (wlan0): supplicant connection
state change: 4 -> 5
Jul  2 06:56:43 barley NetworkManager: <info>  (wlan0): supplicant connection
state change: 5 -> 6
Jul  2 06:56:47 barley NetworkManager: <info>  Activation (wlan0/wireless):
association took too long.
Jul  2 06:56:47 barley NetworkManager: <info>  (wlan0): device state change: 5 -> 6
Jul  2 06:56:47 barley NetworkManager: <info>  Activation (wlan0/wireless):
asking for new secrets
Jul  2 06:56:47 barley NetworkManager: <info>  (wlan0): supplicant connection
state change: 6 -> 0

Comment 1 John W. Linville 2008-07-02 15:14:35 UTC

*** This bug has been marked as a duplicate of 453390 ***


Note You need to log in before you can comment on or make changes to this bug.